Importing database into phpbb

apps

#1

I’m having a very difficult time getting my backed-up data from my old host imported into my board on Dreamhost. I’ve tried it a couple of times and finally resorted to paying for someone to help me. He even is having trouble and says there is a file missing or something. He is using big dump and got this message:

Warning: filesize(): Stat failed for php5.cgi (errno=2 - No such file or directory) in /home/.informant/vincevau/vince-vaughn.com/forum/bigdump.php on line 288

Warning: filemtime(): Stat failed for php5.cgi (errno=2 - No such file or directory) in /home/.informant/vincevau/vince-vaughn.com/forum/bigdump.php on line 288

(http://www.vince-vaughn.com/forum/bigdump.php)

This guy knows a lot about exporting and backing-up and is a frequent poster on the phpbb boards, but even he can’t help. What do I do?


#2

There may be an issue with the size of your upload. Have you tried FTPing your mysql dump up to your server and dumping it in via the ssh command line?

Search the K-base for mysql for further instructions on how to do this.

-Matttail


#3

No, that’s not the problem. The guy who is installing it for me knows how to work with that problem. Here’s what he said:

“I’ve never seen this particular error. But it’s very simple really, a file is missing from the server. The restore program I use needs that file. You’ll need to call up your host and ask them to put it in. It may have been accidentally left out, or may be corrupt. It’s rather easy to fix.”

But anyway, I made a support ticket, so hopefully they will know what to do.

Thank you so much for your reply. I do apppreciate it. :smiley:


#4

I also had that problem with bigdump and DH.
Basically DH PHP/Server configuration doesn’t allow automatic working directory recognision.

Look for this line in bigdump.php:

$upload_dir=dirname($_SERVER[“SCRIPT_FILENAME”]);

and replace it with

$upload_dir = ‘/home/.informant/vincevau/vince-vaughn.com/forum’;

Now when you go to http://www.vince-vaughn.com/forum/bigdump.php it should see all files in their including your sql file :wink:

p.s bigdump worked wonders. Highly recommended.


#5

none of those recommendations work.

Just leave everything as is… insert your BD name / user / pass

and then edit this line:

$filename = “database.sql”; // Specify the dump filename to suppress the file selection dialog

put the filename in that you have in the directory and it will bypass any checks na dgo straight ahead and inprt.

~Vb


#6

well it worked for me :slight_smile:
Note: i changed the directory names based on spidell27 setup.

I havnt tried out your way VB but if it works then sweet as. He’s got options :slight_smile: