Import MySQL databases to new account?


#1

Hi, all:

Newbie to DreamHost, somewhat uncomfortable sophomore at another host I’m inthe process of leaving. A couple of how-the-heck-do-I-get-started questions:

a) I’ve :
Uploaded all my files via FTP
Established 2 databases (users, names, hostnames, passwords, etc.) for my two sites
Tried in vain to access PHPMyAdmin, which seems to require that my domain names already be pointing at DreamHost servers -that’s a step I want to avoid until I get the sites up and running on DreamHost.
Searched Kbase - to no avail - for instrux on uploading my data, exported from my current host databases.
----- How do I do this? Can anyone point me to a Kbase article or forum post pertaining to this? (I’ve checked the beginner’s forum back for a month - no luck)

b) Can I browse my one static (non-DB) web site here using some combination of the domain and the Dreamhost URL? What’s the proper URL for it? (site domain is factoidlabs.com but, as I say, it’s still pointing to my current live hosting company)

Any help will be very much appreciated. I’m under the gun to move all my sites from my current host to this one within 5 days, as they’ve grown too popular for shared hosting.

m

mack reed, editorial consultant, Los Angeles
publisher: http://LAVoice.org
HEAVY LITTLE OBJECTS: http://factoidlabs.com/heavy
home: http://factoidlabs.com


#2

I think you will have to wait for your domain to work to access PHPMyadmin and browsing the site. I don’t know the URL using DH servers…

You can restore your mysql databases through SSH. Login to SSH (using a program like Putty) with your connection to
user_name@domain.com (make sure your user has SSH privs on your User control panel)
then go to your domain folder and locate your backup file.
Then type
mysql -h database.domain.com -u user_name -p --database database_to_use < backup.sql

the --database database_to_use should be the name of the database you want to import information into. If you have a USE command at the top of the sql backup file, you don’t need the --database option, but it doesn’t hurt to have it.


#3

Hey, thanks so much for your fast reply.

Please assume I’m a complete idiot as a DBA - no experience whatsoever, but I think I may have made some progress.

After much trial and error, I finally managed to SSH in, and I think I completed the SQL query to import my database.For instance, I ran the query for each of my two databases and got a huge long server reply that included what appeared to be:

  • an entire help glossary for MySQL
  • A status list that says:

auto-rehash TRUE
character-sets-dir (No default value)
default-character-set latin1
compress FALSE
database (No default value)
delimiter ;
vertical FALSE
force FALSE
named-commands FALSE
local-infile FALSE
no-beep FALSE
host lavoice.lavoice.org
html FALSE
xml FALSE
line-numbers TRUE
unbuffered FALSE
column-names TRUE
sigint-ignore FALSE
port 3306
prompt mysql>
quick FALSE
raw FALSE
reconnect FALSE
socket /var/run/mysqld/mysqld.sock
ssl FALSE
ssl-key (No default value)
ssl-cert (No default value)
ssl-ca (No default value)
ssl-capath (No default value)
ssl-cipher (No default value)
table FALSE
debug-info FALSE
user factoid
safe-updates FALSE
i-am-a-dummy FALSE
connect_timeout 0
max_allowed_packet 16777216
net_buffer_length 16384
select_limit 1000
max_join_size 1000000
secure-auth FALSE

My questions:

  1. Did I succeed? What command should I type to determine whether my data is in there

  2. The “Viewing Your Site Before Your Domain Is Up” article was brief and, sorry to say, confused me.

LAVoice.org (still running at my old server, but uploaded to dreamhost) runs on Postnuke.

Am I correct to assume the following:

  • My server (deblume.dreamhost.com) is running the latest version of PHP?
  • that even if my config.php file is misconfigured (e.g. my database name changed in the move, etc.) that I’d get at least some kind of error message?

I just get the sense I’m not finding the front door to the site to even knock on it because I’m still stumbling around in the bushes across the street.

Any advice?

mack reed, editorial consultant, Los Angeles
publisher: http://LAVoice.org
HEAVY LITTLE OBJECTS: http://factoidlabs.com/heavy
home: http://factoidlabs.com


#4

mysql -h database.domain.com -u user_name -p --database database_to_use > backup.sql

Sorry I put the < arrow the wrong way around -_-

  1. The article says you can’t access your site without a domain set up and propogated. That’s how I’ve read it. So you’ll just have to say on your old site, things might take a week or so to get things back to normal, while your domain changes and you sort any errors out.
    If you have set up your domain with DH when you signed up, and it’s still not active (and it’s been 3 days since you’ve changed anything to do with it) then submit a trouble/support ticket. If you are keeping your old domain provider then make sure you’ve pointed the domain to the right name servers.

ns1.dreamhost.com: 66.33.206.206
ns2.dreamhost.com: 66.201.54.66
ns3.dreamhost.com: 66.33.216.216

k base article about transfering domains


#5

What I did to move a Postnuke site with an almost 1GB DB here:

  • create a domain name of gamejag.dreamhosters.com
  • create my database on that domain
  • upload a recent backup in three pieces via ssh (I also had to create my mySQL dumps with one INSERT per record rather than one per table as I was getting “query too long” errors on my larger tables. IOW, no “extended inserts”.)
  • ftp the site files to gamejag.dreamhosters.com
  • set the DB info in my config.php to the DB here
  • test, test, test
  • set the DB on gamejag.dreamhosters.com to accept connections from the original site
  • take the original site offline while I made a new backup and inserted it over the old one on gamejag.dreamhosters.net (DROP and INSERT)
  • point the config.php on the old site to the DB here
  • test
  • let people back into the old site, now running off the new DB
  • set gamejag.com, etc., to be mirrors of gamejag.dreamhosters.com
  • change nameservers

All told, gamejag was unavailable for about six hours during the final backup/upload, and the switch from one host to the other as the DNS propagated would have been invisible to the users had there not been a problem with actually getting the nameservers changed over. The DB is still on gamejag.dreamhosters.com, and I see no reason why I shouldn’t leave it there.


#6

Hmmm. Reversing the arrow gives me a “Permission denied” though I’ve triple-checked the password, db name, username, etc.

mysql -L -h lavoice.lavoice.org -u factoid -p PASSWORD lavoice < lavoice_localhost.sql

(PASSWORD is, of course, replaced with my DB pw in the query I tried)

Further - I wish I could tell people I’ll be down for a week, but I’m getting 1,000 to 1,500 visits a day. It’s a pretty popular newsblog that just had a ton of new eyeballs driven to it by an L.A. Magazine article, and I’d hate to squander that.

Gamejag (in the next message) offers what seems to be a path toward a solution. I’ll give it a try and report back.

Thanks so much to everyone for the helpful advice. I think I have about three days left until my current host turns into a pumpkin. I’ll keep you posted.

mack reed, editorial consultant, Los Angeles
publisher: http://LAVoice.org
HEAVY LITTLE OBJECTS: http://factoidlabs.com/heavy
home: http://factoidlabs.com


#7

Sorry. Duh. I chmod’d 775 the files, and re-ran the commands. Now I get nothing back. Just a new prompt:

[deblume]$ mysql -L -h lavoice.lavoice.org -u factoid -p PASSWORD lavoice > lavoice_localhost.sql
[deblume]$

mack reed, editorial consultant, Los Angeles
publisher: http://LAVoice.org
HEAVY LITTLE OBJECTS: http://factoidlabs.com/heavy
home: http://factoidlabs.com


#8

ardco said:

That’s exactly what happened. I was following what appeared to be an instruction from decswxaqz, who said:

[quote]mysql -h database.domain.com -u user_name -p --database database_to_use > backup.sql

Sorry I put the < arrow the wrong way around -_-[/quote]

So - I reuploaded my backup file and ran the query:

What I can’t tell is whether the query succeeded in populating my database. The response I got back (forgive the long post here, but I’m quoting it at full length) said:

[quote]mysql Ver 14.7 Distrib 4.1.8, for pc-linux (i386)
Copyright © 2002 MySQL AB
This software comes with ABSOLUTELY NO WARRANTY. This is free software,
and you are welcome to modify and redistribute it under the GPL license
Usage: mysql [OPTIONS] [database]
-?, --help Display this help and exit.
-I, --help Synonym for -?
–auto-rehash Enable automatic rehashing. One doesn’t need to use
’rehash’ to get table and field completion, but startup
and reconnecting may take a longer time. Disable with
–disable-auto-rehash.
-A, --no-auto-rehash
No automatic rehashing. One has to use ‘rehash’ to get
table and field completion. This gives a quicker start of
mysql and disables rehashing on reconnect. WARNING:
options deprecated; use --disable-auto-rehash instead.
-B, --batch Don’t use history file. Disable interactive behavior.
(Enables --silent)
–character-sets-dir=name
Directory where character sets are.
–default-character-set=name
Set the default character set.
-C, --compress Use compression in server/client protocol.
-#, --debug[=#] This is a non-debug version. Catch this and exit
-D, --database=name Database to use.
–delimiter=name Delimiter to be used.
-e, --execute=name Execute command and quit. (Disables --force and history
file)
-E, --vertical Print the output of a query (rows) vertically.
-f, --force Continue even if we get an sql error.
-g, --no-named-commands
Named commands are disabled. Use * form only, or use
named commands only in the beginning of a line ending
with a semicolon (:wink: Since version 10.9 the client now
starts with this option ENABLED by default! Disable with
’-G’. Long format commands still work from the first
line. WARNING: option deprecated; use
–disable-named-commands instead.
-G, --named-commands
Enable named commands. Named commands mean this program’s
internal commands; see mysql> help . When enabled, the
named commands can be used from any line of the query,
otherwise only from the first line, before an enter.
Disable with --disable-named-commands. This option is
disabled by default.
-i, --ignore-spaces Ignore space after function names.
–local-infile Enable/disable LOAD DATA LOCAL INFILE.
-b, --no-beep Turn off beep on error.
-h, --host=name Connect to host.
-H, --html Produce HTML output.
-X, --xml Produce XML output
–line-numbers Write line numbers for errors.
-L, --skip-line-numbers
Don’t write line number for errors. WARNING: -L is
deprecated, use long version of this option instead.
–no-pager Disable pager and print to stdout. See interactive help
(\h) also. WARNING: option deprecated; use
–disable-pager instead.
–no-tee Disable outfile. See interactive help (\h) also. WARNING:
option deprecated; use --disable-tee instead
-n, --unbuffered Flush buffer after each query.
–column-names Write column names in results.
-N, --skip-column-names
Don’t write column names in results. WARNING: -N is
deprecated, use long version of this options instead.
-O, --set-variable=name
Change the value of a variable. Please note that this
option is deprecated; you can set variables directly with
–variable-name=value.
–sigint-ignore Ignore SIGINT (CTRL-C)
-o, --one-database Only update the default database. This is useful for
skipping updates to other database in the update log.
–pager[=name] Pager to use to display results. If you don’t supply an
option the default pager is taken from your ENV variable
PAGER. Valid pagers are less, more, cat [> filename],
etc. See interactive help (\h) also. This option does not
work in batch mode.
-p, --password[=name]
Password to use when connecting to server. If password is
not given it’s asked from the tty. WARNING: This is
insecure as the password is visible for anyone through
/proc for a short time.
-P, --port=# Port number to use for connection.
–prompt=name Set the mysql prompt to this value.
–protocol=name The protocol of connection (tcp,socket,pipe,memory).
-q, --quick Don’t cache result, print it row by row. This may slow
down the server if the output is suspended. Doesn’t use
history file.
-r, --raw Write fields without conversion. Used with --batch.
–reconnect Reconnect if the connection is lost. Disable with
–disable-reconnect. This option is enabled by default.
-s, --silent Be more silent. Print results with a tab as separator,
each row on new line.
-S, --socket=name Socket file to use for connection.
–ssl Enable SSL for connection (automatically enabled with
other flags). Disable with --skip-ssl.
–ssl-key=name X509 key in PEM format (implies --ssl).
–ssl-cert=name X509 cert in PEM format (implies --ssl).
–ssl-ca=name CA file in PEM format (check OpenSSL docs, implies
–ssl).
–ssl-capath=name CA directory (check OpenSSL docs, implies --ssl).
–ssl-cipher=name SSL cipher to use (implies --ssl).
-t, --table Output in table format.
-T, --debug-info Print some debug info at exit.
–tee=name Append everything into outfile. See interactive help (\h)
also. Does not work in batch mode.
-u, --user=name User for login if not current user.
-U, --safe-updates Only allow UPDATE and DELETE that uses keys.
-U, --i-am-a-dummy Synonym for option --safe-updates, -U.
-v, --verbose Write more. (-v -v -v gives the table output format).
-V, --version Output version information and exit.
-w, --wait Wait and retry if connection is down.
–connect_timeout=# Number of seconds before connection timeout.
–max_allowed_packet=#
Max packet length to send to, or receive from server
–net_buffer_length=#
Buffer for TCP/IP and socket communication
–select_limit=# Automatic limit for SELECT when using --safe-updates
–max_join_size=# Automatic limit for rows in a join when using
–safe-updates
–secure-auth Refuse client connecting to server if it uses old
(pre-4.1.1) protocol

Default options are read from the following files in the given order:
/etc/mysql/my.cnf /var/lib/mysql/my.cnf ~/.my.cnf
The following groups are read: mysql client
The following options may be given as the first argument:
–print-defaults Print the program argument list and exit
–no-defaults Don’t read default options from any options file
–defaults-file=# Only read default options from the given file #
–defaults-extra-file=# Read this file after the global files are read

Variables (–variable-name=value)
and boolean options {FALSE|TRUE} Value (after reading options)


auto-rehash TRUE
character-sets-dir (No default value)
default-character-set latin1
compress FALSE
database (No default value)
delimiter ;
vertical FALSE
force FALSE
named-commands FALSE
local-infile FALSE
no-beep FALSE
host lavoice.lavoice.org
html FALSE
xml FALSE
line-numbers TRUE
unbuffered FALSE
column-names TRUE
sigint-ignore FALSE
port 3306
prompt mysql>
quick FALSE
raw FALSE
reconnect FALSE
socket /var/run/mysqld/mysqld.sock
ssl FALSE
ssl-key (No default value)
ssl-cert (No default value)
ssl-ca (No default value)
ssl-capath (No default value)
ssl-cipher (No default value)
table FALSE
debug-info FALSE
user factoid
safe-updates FALSE
i-am-a-dummy FALSE
connect_timeout 0
max_allowed_packet 16777216
net_buffer_length 16384
select_limit 1000
max_join_size 1000000
secure-auth FALSE[/quote]
Am I anywhere near doing this correctly?

mack reed, editorial consultant, Los Angeles
publisher: http://LAVoice.org
HEAVY LITTLE OBJECTS: http://factoidlabs.com/heavy
home: http://factoidlabs.com


#9

Folks:

Thanks to all for all your suggestions, but after 24 hours of banging my head against this, I’ve decided to throw myself upon the mercy of the support staff.

I’m just not strong enough intuitively to grasp where things are going wrong, and I fear I’m wasting your time by coming back over and over again with my little baby-steps failiures.

Again, thanks so much for your generous help. I promise you, once I’m set up, I have a reasonably comfortable time of it, but I’m an HTML coder with a drop-dead 3-day deadline, not a wiz-bang DBA so I need to let DH support handle this directly. I’ll let you know how it goes.

chrs,

m

Any gluttons for punishment out there are welcome to read my Support request:

mack reed, editorial consultant, Los Angeles
publisher: http://LAVoice.org
HEAVY LITTLE OBJECTS: http://factoidlabs.com/heavy
home: http://factoidlabs.com


#10

Considering the DH support wait list is 438 requests long, I’m still pecking away at it on my own. My previous attempts had all been from the DH server prompt, but I also have tried logging onto the DB itself to run the command, like this:

[quote]mysql> mysql -L -h hlo.factoidlabs.com -u factoid -p su3n0bu3n0 hlo < /home/factoid/heavy_localhost.sql;
ERROR 1064 (00000): You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'mysql -L -h hlo.factoidlabs.com -u factoid -p su3n0bu3n0 hlo < ;[/quote]
a) Am I right to try this command while logged in at MySQL and
b) if so, can anyone point out what’s wrong with my syntax?

mack reed, editorial consultant, Los Angeles
publisher: http://LAVoice.org
HEAVY LITTLE OBJECTS: http://factoidlabs.com/heavy
home: http://factoidlabs.com


#11

What command did you use to get the mysql> prompt? I thought the mysql command was only usable from a $ prompt?

You’re still trying to connect to a DB host on factoidlabs.com. Since the DNS still points to your old host, you’re actually trying to connect to a subdomain on the old host that presumably doesn’t exist. Dreamhost’s computers can’t figure out that you really don’t want them sending your request to your old host’s machine, since you haven’t given a address change yet.

Try going to Domains->Add Domain on your panel and adding “factoidlabs.dreamhosters.com”, then (once that’s finished setting up) to Goodies->MySQL and create a DB on there, say at a host named hlo.factoidlabs.dreamhosters.com.

Once that’s ready, go to your shell and (at a $ prompt) connect with “mysql -h hlo.factoidlabs.dreamhosters.com -u factoid -p” and put in your password at the prompt.

At the mysql> prompt, type “connect DATABASE;” where DATABASE is the database name.

At the next prompt, type “source /home/factoid/heavy_localhost.sql;” and watch it go. Assuming, of course, that this sql file has all the ADD TABLE and INSERT commands necessary to rebuild your DB. You may need to go back the the phpMyAdmin on the old host and create a new dump file if this one doesn’t work, depending on what errors it throws.


#12

Actually, the DNS is pointing to DreamHost now, and has been all along. Proof of this, is that my home page resolves at DH:
http://factoidlabs.com

The problem lies (of course) in my ignorance, but following your instructions, and using the connection string provided by the DreamHost MySQL setup tool, here’s the entire transcript of a session that I just tried:

[quote]Last login: Mon Jan 31 05:52:44 on ttyp1
Welcome to Darwin!
mack-reeds-Computer:~ mackreed$ ssh factoid@deblume.dreamhost.com
Password:
Last login: Mon Jan 31 05:52:58 2005 from lsanca1-ar10-4-60-086-063.lsanca1.dsl-verizon.net on pts/0
Linux deblume 2.6.10-grsec+gg3+e+fhs6b+nfs+gr0501+++p4+c4a+gr2b-v6.189 #1 SMP Tue Jan 11 12:49:01 PST 2005 i686 unknown
’|| ‘|| ‘||
… || … || … || … … … … … …
.’ ‘|| .|…|| ||’ || || || || || || || .|…||
|. || || || | || || || || || || ||
’|…’||. ‘|…’ ‘|…’ .||. ‘|…’|. .|| || ||. ‘|…’

Welcome to deblume.dreamhost.com

Any malicious and/or unauthorized activity is strictly forbidden.
All activity may be logged by DreamHost Web Hosting.

Last login: Mon Jan 31 05:52:58 2005 from lsanca1-ar10-4-60-086-063.lsanca1.dsl-verizon.net
[deblume]$ mysql -u factoid -p -h hlo.factoidlabs.com hlo
Enter password:
Welcome to the MySQL monitor. Commands end with ; or \g.
Your MySQL connection id is 8229 to server version: 4.0.20-log

Type ‘help;’ or ‘\h’ for help. Type ‘\c’ to clear the buffer.

mysql> source/home/factoid/hlo.txt;
ERROR 1064 (00000): You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near ‘source/home/factoid/hlo.txt’ at line 1
mysql> source/home/factoid/hlo.txt;[/quote]
The response has been identical in virtually every query I’ve tried. I checked the commands in the DB file itself, but line 1 seems to be nothing more than a comment, and the first CREATE TABLE command doesn’t look too weird (but then I’m not a MySQL guy):

[quote]-- phpMyAdmin SQL Dump
– version 2.6.0-pl3
http://www.phpmyadmin.net

– Host: localhost
– Generation Time: Jan 30, 2005 at 03:56 PM
– Server version: 4.0.22
– PHP Version: 4.3.9

– Database: hlo



– Table structure for table mt_author

CREATE TABLE mt_author (
author_id int(11) NOT NULL auto_increment,
author_name varchar(50) NOT NULL default ‘’,
author_type tinyint(4) NOT NULL default ‘0’,
author_nickname varchar(50) default NULL,
author_password varchar(60) NOT NULL default ‘’,
author_email varchar(75) NOT NULL default ‘’,
author_url varchar(255) default NULL,
author_can_create_blog tinyint(4) default NULL,
author_can_view_log tinyint(4) default NULL,
author_hint varchar(75) default NULL,
author_created_by int(11) default NULL,
author_public_key text,
author_preferred_language varchar(50) default NULL,
author_remote_auth_username varchar(50) default NULL,
author_remote_auth_token varchar(50) default NULL,
PRIMARY KEY (author_id),
UNIQUE KEY author_name (author_name,author_type),
KEY author_email (author_email)
) TYPE=MyISAM AUTO_INCREMENT=2 ;

[/quote]
Just not sure where to go from here.

mack reed, editorial consultant, Los Angeles
publisher: http://LAVoice.org
HEAVY LITTLE OBJECTS: http://factoidlabs.com/heavy
home: http://factoidlabs.com


#13

Looks good to my inexpert eyes except for:

Need a space between “source” and “/”. And is the file a .txt or a .sql? just checking; .sql is the usual default.

I made certain I was in the same directory as the dump file before I connected to the sql host (“cd factoid.com”, most likely, for your directory tree) and didn’t include path information when i executed the sql dump. (“source gamejag_posttext.sql” for one of my dumps.)


#14

You can’t import a file (to my knowledge) directly into MySQL that will add table structure. MySQL DATA INFILE.
That only seems to add data and not structure. You can use mysqlimport command or mysql command using switches and pipes. I think that’s your best bet.


#15

Changed the filename back to a .sql, went into the directory where the file resides, made sure it was chmod 775, connected to the database via the string supplied by DH, and here’s what I get:

[quote]mysql> source hlo hlo.sql
ERROR:
Failed to open file ‘hlo hlo.sql’, error: 2[/quote]

mack reed, editorial consultant, Los Angeles
publisher: http://LAVoice.org
HEAVY LITTLE OBJECTS: http://factoidlabs.com/heavy
home: http://factoidlabs.com


#16

Sorry, but unfortunately that’s complete rocket science to me.

I’m just an HTML guy struggling to get his sites moved before my old host destroys them, not an experienced MySQL user at all.

I’m not sure what pipes are, what the correct syntaxt for using them would be, or any of the rest of it.

Here’s my latest try:

1 - the DNS info points to my site at DH servers (http://factoidlabs.com)

2 - the DB is uploaded and chmod’d to 775 as hlo.sql in the site’s root folder (/home/factoid/factoidlabs.com

3 - I CD’d to that folder

4 - I connected to the DB using the connection string supplied by DH

5 - here’s what I get, using gamejag’s suggestion, and then yours:

mack reed, editorial consultant, Los Angeles
publisher: http://LAVoice.org
HEAVY LITTLE OBJECTS: http://factoidlabs.com/heavy
home: http://factoidlabs.com


#17

A sql dump from phpMyAdmin is a script with CREATE TABLEs and INSERTs that can be run via the source command from the mysql shell. I can’t point you to a man page, but I know it works. :slight_smile:


#18

Just “source hlo.sql;”. You’re already connected to the database via the mysql command.

Everything after the word “source” is expected to be part of the filename of the script you want to run. That script is your phpMyAdmin sql dump.

PS: I’m not a SQL expert, either. I just had the good fortune to have one handy to hold my hand through a similar move.


#19

Well, it definitely didn’t like what I fed it - which was definitely the unaltered dump from PHPMyAdmin at the old host:

[quote]mysql> source hlo.sql
ERROR 1064 (00000): You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'author_idint(11) NOT NULL auto_increment,author_namevar ERROR 1064 (00000): You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'blog_id int(11) NOT NULL auto_increment,
blog_name varchar
ERROR 1064 (00000): You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'category_idint(11) NOT NULL auto_increment,category_blog_
ERROR 1064 (00000): You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'comment_idint(11) NOT NULL auto_increment,comment_blog_id
ERROR 1064 (00000): You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'entry_idint(11) NOT NULL auto_increment,entry_blog_idin ERROR 1064 (00000): You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'ext_bl_group_id int(11) NOT NULL auto_increment,
ext_bl_gro ERROR 1064 (00000): You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'ext_bl_groupmap_id int(11) NOT NULL auto_increment,
ext_bl_ ERROR 1064 (00000): You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'ext_bl_item_id int(11) NOT NULL auto_increment,
ext_bl_item ERROR 1064 (00000): You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'ext_bl_log_id int(11) NOT NULL auto_increment,
ext_bl_log_g ERROR 1064 (00000): You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'ext_bl_permission_id int(11) NOT NULL auto_increment,
ext_b ERROR 1064 (00000): You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'ext_bl_source_id int(11) NOT NULL auto_increment,
ext_bl_so ERROR 1064 (00000): You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'ext_bl_update_id int(11) NOT NULL auto_increment,
ext_bl_up ERROR 1064 (00000): You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'fileinfo_id int(11) NOT NULL auto_increment,
fileinfo_blog_ ERROR 1064 (00000): You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'ipbanlist_id int(11) NOT NULL auto_increment,
ipbanlist_blo ERROR 1064 (00000): You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'log_id int(11) NOT NULL auto_increment,
log_message varcha
ERROR 1064 (00000): You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'notification_idint(11) NOT NULL auto_increment,notificati
ERROR 1064 (00000): You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'permission_idint(11) NOT NULL auto_increment,permission_a
ERROR 1064 (00000): You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'placement_idint(11) NOT NULL auto_increment,placement_ent
ERROR 1064 (00000): You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'plugindata_idint(11) NOT NULL auto_increment,plugindata_p
ERROR 1064 (00000): You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'session_idvarchar(80) NOT NULL default '',session_datat ERROR 1064 (00000): You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'tbping_id int(11) NOT NULL auto_increment,
tbping_blog_id
ERROR 1064 (00000): You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'template_idint(11) NOT NULL auto_increment,template_blog_
ERROR 1064 (00000): You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'templatemap_idint(11) NOT NULL auto_increment,templatemap
ERROR 1064 (00000): You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'trackback_idint(11) NOT NULL auto_increment,trackback_blo
ERROR 1064 (00000): You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'cat_IDint(4) NOT NULL auto_increment,cat_namevarchar(55 ERROR 1064 (00000): You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'comment_ID int(11) unsigned NOT NULL auto_increment,
commen ERROR 1064 (00000): You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'cat_id int(11) NOT NULL auto_increment,
cat_name tinytext
ERROR 1064 (00000): You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'link_idint(11) NOT NULL auto_increment,link_urlvarchar( ERROR 1064 (00000): You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'group_id int(11) NOT NULL default ‘0’,
option_id int(11) N
ERROR 1064 (00000): You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'group_idint(11) NOT NULL auto_increment,group_namevarch ERROR 1064 (00000): You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'option_id int(11) NOT NULL auto_increment,
blog_id int(11)
ERROR 1064 (00000): You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'optiontype_idint(11) NOT NULL auto_increment,optiontype_n
ERROR 1064 (00000): You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'option_idint(11) NOT NULL default '0',optionvaluetinyte ERROR 1064 (00000): You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'rel_id int(11) NOT NULL auto_increment,
post_id int(11) NO
ERROR 1064 (00000): You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'meta_idint(11) NOT NULL auto_increment,post_idint(11) N ERROR 1064 (00000): You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'ID int(10) unsigned NOT NULL auto_increment,
post_author i
ERROR 1064 (00000): You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'IDint(10) unsigned NOT NULL auto_increment,user_login` va[/quote]

mack reed, editorial consultant, Los Angeles
publisher: http://LAVoice.org
HEAVY LITTLE OBJECTS: http://factoidlabs.com/heavy
home: http://factoidlabs.com


#20

We’re making progress, though. :slight_smile:

Do you still have access to the old DB? Without seeing your .sql file, I can’t suggest what might be happening, so the best thing might be to create a new dump and make sure you have all the right boxes checked.