Import mail issues


#1

Hi, I just created my domain and an email account. I am trying to migrate my mailbox contents from elsewhere into the new account. Currently unable to, run into the following problems

  • mailutil is not available
  • Used mb2md to create the Maildir set of directories and files. Awesome. Can’t see the messages on my email client though.

Reason is, I guess, that my shell account on niners does not get visibility of my email account on homie or whatever. Three questions then:

  • What is the point of having a Maildir set of directories on my shell account? They were there waiting for me on my first login
  • Where is the information on how to transfer files/messages to my email account(s)? More importantly, where is the information on where and how are imap mailboxes being kept/stored/maintained?
  • Can someone on dreamhost do this file transfer for me? Without killing the few messages already on my current inbox? I’ve filed a support request as well …

Thanks,
Andres


#2

Think of real post mail where either mail comes to your residence or a mail drop off location. DreamHost has switched to the “mail drop off location” where separate mail servers recieve and store mail. However you can still get mail dropped off at your “residence” if it is specifically addressed to it: username@machine.dreamhost.com

The simplest way to transfer messages from one mailbox to another (especially if the destination is IMAP) is to install a mail client like Mozilla Thunderbird that can setup multiple accounts so that you can just drag messages and folders to the IMAP destination account using your mouse!

Secondly, mailutil is available! If DreamHost doesn’t have it installed already, install it yourself to your shell account.

[code]> wget ftp://ftp.cac.washington.edu/pine/bin/mailutil-bin.linux-deb3.Z

[quote]zcat mailutil-bin.linux-deb3.Z > mailutil
chmod u x mailutil[/code]
[/quote]

Send me a private message.

:cool: openvein.org -//-


#3

Hey, thanks for chiming in. Sorry to say that mailutil is not avaiable, at least in niners. I followed your instructions for getting the pre-built binary. It’s
a) a 32bit binary which scares me due to pine source code’s ridiculous amount of integer to pointer casting
b) still doesn’t work because it links against ssl library versions not available

[niners]$ ./mailutil
./mailutil: error while loading shared libraries: libssl.so.0.9.7: cannot open shared object file: No such file or directory
[niners]$ ldd mailutil
linux-gate.so.1 => (0xf7f2b000)
libpam.so.0 => /lib32/libpam.so.0 (0xf7f15000)
libdl.so.2 => /lib32/libdl.so.2 (0xf7f11000)
libssl.so.0.9.7 => not found
libcrypto.so.0.9.7 => not found
libc.so.6 => /lib32/libc.so.6 (0xf7de5000)
/lib/ld-linux.so.2 (0xf7f2c000)

Maybe it’s time to add mailutil to niners?
Andres


#4

Problem solved

  1. Scp’ed my mbox files to my shell dreamhost account
  2. Got pine 4.64 source from U Washington, and unpacked
  3. In the pine source dir, did ./build ldb
  4. Notice the scary amount of integer to cast happening for a 32bit build on a 64bit machine. You’re totally on your own here
  5. bin/mailutil ready in the pine source dir. Use according to
    http://wiki.dreamhost.com/E-mail_Import#Transfer_using_mailutil

So far so good,
Andres