IMAP problems

apps

#1

I’d very much like to replace SquirrelMail, and have just spent the weekend attempting to do so. I’ve tried both Horde and RoundCube, and I can’t get either of them to work reliably.

First, Horde. I compiled a custom PHP interpreter. It’s got everything Horde needs - all the PEAR libraries, the IMAP c-client library, and all. Horde runs. But it can only talk to the IMAP server about 10% of the time. Here, check these screen shots of the IMP test suite, which tests four different ways of talking to the IMAP server:

http://atuan.com/test1.png
http://atuan.com/test2.png
http://atuan.com/test3.png

In the first test, methods 1 and 2 don’t work, but 3 and 4 work fine.

In the second test, about half an hour later, with NO CHANGES from me, it reports that all four methods fail.

In the third test, about a half hour after the second test, it reports that all of the methods work except for method 2.

I’ve tried every configuration I can think of, and nothing works reliably. Sometimes I can log into Horde, but not Imp; sometimes I can’t log in at all; sometimes I can log into both, but I get weird errors saying that the IMAP server sent an “unknown response.” Here’s a typical response entry from the log:

Aug 19 23:05:58 HORDE [error] [imp] FAILED LOGIN 128.83.211.24 to mail.atuan.com:143[imap/tls/novalidate-cert] as foobar@atuan.com [on line 258 of “/home/.siani/selanit/atuan.com/horde/imp/lib/Auth/imp.php”]

(Note that I’ve replaced my email address with a fake one here.) Line 258 is part of the function that opens a channel to the IMAP server.

After struggling with Horde till I got cross-eyed, I decided to try RoundCube. Configuration was much easier; and it doesn’t work. I managed to log in and read my email, once, and then it stopped working. Most of the time it dies at log in: I’ll enter my info, submit, and then I get zero response from the server - no return data whatsoever. The RoundCube logs are full of this kind of thing:

[20-Aug-2007 01:27:51] PHP Fatal error: Maximum execution time of 120 seconds exceeded in /home/.siani/selanit/atuan.com/roundcube/program/lib/imap.inc on line 134

This too is from the function that creates a new IMAP connection.

I’ve even tried logging into the IMAP server manually via telnet, and that didn’t work either.

Yet SquirrelMail keeps working fine. I’m stumped. How can I persuade the IMAP server to play nice with Horde or Roundcube? Box of chocolates and some sweet talk? >.<


#2

I’m getting the exact same problem implementing roundcube. It seems to be load related to me.

What server are you on?


#3

My email server is janky. You?

I’ve filed a support ticket. I hope they don’t blow me off; reliable webmail (WITH identity management and filters) is actually the only reason I want a domain at all.


#4

Same, my email server is janky also.

I logged a ticket and they told me that my roundcube install was the problem and disabled it. I have just finished downloading the nightly release off trac and it still does the same thing.

Personally I don’t think it is roundcube… Lets hope you have more luck, let me know how you go.

Daniel


#5

They told me it was my Horde install, and didn’t refer to Roundcube. The support rep asserts that everything checks out on their end, and that it must be a problem on mine. He never addressed why I might be getting identical symptoms in two different email clients with completely separate codebases. He did ask to see a traceroute from my machine to the mail server; I sent him one and he hasn’t gotten back yet.

I remain convinced that this is some kind of problem with the mail server. Both Roundcube and Horde are getting their IMAP connections dropped, and it’s happened from both my home computer and computers at my workplace.

This is not acceptable - I will wait to hear what the support rep has to say about my traceroute (though I’m not sure why it’s relevant). If the problem doesn’t get fixed, I’m going to fix it by abandoning Dreamhost. I need reliable webmail. It is my sole requirement in a web host. If they can’t do it, well, I’m just glad I’m still in my 97-day refund period.


#6

Not much to add, but I’m having the exact same problem trying to get roundcube working. I’m on janky as well… :frowning:


#7

ok, thats 3 people having the same problem with janky… I will try support again but this is bullshit… im in the same boat webmail is the main reason I signed up.


#8

I indirectly got an update. I was putting together a script to process some items from a mailbox, but though pop and ran into the same problem. When I reported it to support they acknowledged there is a known problem with accessing the janky cluster from the web servers. Their suggested workaround was to access the server jankymail-a1 directly instead of mail.domain.com. This worked for both my script and seems to be working for roundcube as well.

They promised to update the status blog when the issue is resolved and we can switch back to mail.domain.com.


#9

Hi , i got the same problem ¿how can i access jankymail-a1 directly instead of mail.domain.com?

Thank you very much :slight_smile: