ImageMagick Problem with Gallery

apps

#1

Hi,

I have installed image gallery(one click). But ImageMagick is not working(thumbnails problem). I have tested it with the test function in gallery under Admin Options->Gallery Plugins-> ImageMagick Settings.

This is what i get:

is_dir(/usr/bin/)
Loading plugin imagemagick
imagemagick plugin successfully instantiated
Check the version of the imagemagick plugin
The version of the imagemagick plugin is ok
getcwd()
chdir(/home/lfsnorge/lfsnorge.net_gallery_g2data/tmp/)
file_exists(/usr/bin/gm)
file_exists(/usr/bin/identify)
getParameter exec.beNice for core plugin
Executing: ( “/usr/bin/identify”
"/home/.ishta/lfsnorge/lfsnorge.net/gallery/modules/imagemagick/data/test.gif"
) 2>"/home/lfsnorge/lfsnorge.net_gallery_g2data/tmp/g2dbgD9zU8t"
getParameter exec.expectedStatus for core plugin
file_exists(/home/lfsnorge/lfsnorge.net_gallery_g2data/tmp/g2dbgD9zU8t)
filesize(/home/lfsnorge/lfsnorge.net_gallery_g2data/tmp/g2dbgD9zU8t)
unlink(/home/lfsnorge/lfsnorge.net_gallery_g2data/tmp/g2dbgD9zU8t)
Regular Output:
Error Output:
Status: (expected 0)
file_exists(/usr/bin/gm)
tempnam(/home/lfsnorge/lfsnorge.net_gallery_g2data/tmp/, imgk_)
file_exists(/usr/bin/convert)
Executing: ( “/usr/bin/convert” “-size” “200x200” “-geometry” “200x200"
”/home/.ishta/lfsnorge/lfsnorge.net/gallery/modules/imagemagick/data/test.gif"
"/home/lfsnorge/lfsnorge.net_gallery_g2data/tmp/imgk_oO4SdO" )
2>"/home/lfsnorge/lfsnorge.net_gallery_g2data/tmp/g2dbgBTRB18"
file_exists(/home/lfsnorge/lfsnorge.net_gallery_g2data/tmp/g2dbgBTRB18)
filesize(/home/lfsnorge/lfsnorge.net_gallery_g2data/tmp/g2dbgBTRB18)
unlink(/home/lfsnorge/lfsnorge.net_gallery_g2data/tmp/g2dbgBTRB18)
Regular Output:
Error Output:
Status: (expected 0)
unlink(/home/lfsnorge/lfsnorge.net_gallery_g2data/tmp/imgk_oO4SdO)
file_exists(/usr/bin/gm)
file_exists(/usr/bin/combine)
file_exists(/usr/bin/composite)
is_executable(/usr/bin/composite)
file_exists(/usr/bin/gm)
tempnam(/home/lfsnorge/lfsnorge.net_gallery_g2data/tmp/, imgk_)
Executing: ( “/usr/bin/composite” “-geometry” " 0 0"
"/home/.ishta/lfsnorge/lfsnorge.net/gallery/modules/imagemagick/data/test.jpg"
"/home/.ishta/lfsnorge/lfsnorge.net/gallery/modules/imagemagick/data/test.gif"
"/home/lfsnorge/lfsnorge.net_gallery_g2data/tmp/imgk_VhRRSR" )
2>"/home/lfsnorge/lfsnorge.net_gallery_g2data/tmp/g2dbgD6FAVA"
file_exists(/home/lfsnorge/lfsnorge.net_gallery_g2data/tmp/g2dbgD6FAVA)
filesize(/home/lfsnorge/lfsnorge.net_gallery_g2data/tmp/g2dbgD6FAVA)
unlink(/home/lfsnorge/lfsnorge.net_gallery_g2data/tmp/g2dbgD6FAVA)
Regular Output:
Error Output:
Status: (expected 0)
unlink(/home/lfsnorge/lfsnorge.net_gallery_g2data/tmp/imgk_VhRRSR)
chdir(/home/.ishta/lfsnorge/lfsnorge.net/gallery)


#2

Any suggestions ?


#3

Path problem in a config somewhere?

tempnam(/home/lfsnorge/lfsnorge.net_gallery_g2data/tmp/, imgk_)

Maximum Cash Discount on any plan with MAXCASH


#4

[quote]Path problem in a config somewhere?

tempnam(/home/lfsnorge/lfsnorge.net_gallery_g2data/tmp/, >imgk_)
[/quote]

the directory exists…

I have tried to run this command manually and it works fine.
$ /usr/bin/convert -size 200x200 -geometry 200x200 /home/.ishta/lfsnorge/lfsnorge.net/gallery/modules/imagemagick/data/test.gif /home/lfsnorge/lfsnorge.net_gallery_g2data/tmp/blh

btw the testfiles were missing from the /home/.ishta/lfsnorge/lfsnorge.net/gallery/modules/imagemagick/data/ directory. I am not sure if that is normal ?