IE Problem

design

#1

Not sure if this should go in here or in the troubleshooting, but the thing is i have some issues in Internet Explorer with my photoblog. I tried to move it on a different server and it works pretty normal, here with dreamhost it’s a bit messed up.
The url of my photoblog is www.staychill.net/pixel
Please check it on firefox, then on IE
After that see http://www.sotolicious.com/delicious/ again on both Firefox and IE and notice the difference

Anyone knows what might it be?


#2

My guess is that the CSS is being applied differently by both browsers due to the fact that the document isn’t valid XHTML. I think DOCTYPE switching is being handled differently by the two browsers.

si-blog
Max discount on any plan with promocode SCJESSEYTOTAL


#3

i returned to my previous theme
this also looks different on IE on dreamhost and other webhosts

What’s that doctype thing you were saying, should i change it?


#4

Your markup isn’t valid. Validate your markup with the W3C validator and it will point out some of the problems you will need to fix.

si-blog
Max discount on any plan with promocode SCJESSEYTOTAL


#5

i tried doing that… i just don’t know where i’m doing wrong


#6

Let me give you an example. You are using the element, but that element does not exist in XHTML (it is available, though deprecated, in HTML). Also, you have tried to put a table inside a paragraph. Although these will seem like minor problems, they will result in differences in the way the page is rendered by different browsers.

si-blog
Max discount on any plan with promocode SCJESSEYTOTAL


#7

This puzzles me, in that what host the page is served from should have no bearing on how it is displayed, and I have never seen the host make a difference at all. :wink:

–rlparker


#8

i edited as much as i could… i still got 2 errors in the header with the doctype… any clue on how to clear them?


#9

I think the error is coming from your text editor. I believe it is placing a BOM (Byte Order Mark) at the beginning of the document, and the validator is complaining because it is expecting the DOCTYPE declaration to come first. Usually, this is a setting in the options of the text editor.

si-blog
Max discount on any plan with promocode SCJESSEYTOTAL


#10

the error was actually from a php file and not from the html template… i could have look over it thousands of time i still wouldnt have find the answer. decided to reupload everything and works just fine now. perfect valid

what a stupid thing to think that it was from dreamhost :stuck_out_tongue: