IE and OnClick

Hi all, this might be a really stupid question, but I’ve got links on my page to open in a small window with the OnClick=“open.window . . .” and it works fine with FF, but IE seems to think it’s activeX or something ‘harmful’. It does work when you allow the content, but I’m sure people will think doing this will destroy their computers or something.

Here’s what I’m using just for reference:

So is there anyway to make IE behave properly? Idealy I’d just make everyone use FF, but I know that aint gunna happen. Anyway, thanks for any help!

What if you tried changing the target instead? That way the same effect should occur, but IE feels “safer” because it chooses how. Yes, you’ll lose the control over window size, but I think trying to modify that is part and parcel to the message occuring. Try this…

Try this and see if it helps,
onClick=“‘URL’,‘Name of window’,config=‘width=640,height=480’)”

My website

Thanks guys, Pan - I’ll use that if I can’t get this working, I wanted to open fullsize images in small windows minus the address bar etc.
Silk - Didn’t work, IE still has a fit over it. This is why I hate IE.

Would it work better if I used a javascript function?

Weird as it works perfect on my site with IE. Make sure you use th the link as it is required for IE. The href link should be the original web page, making the orginal page reload.

My website

Probably a dumb question, but have you also tried it like this? I can sort of see how it might make a difference to the popup blocker. Mainly because clicking the link is explicitly requesting the operation, instead of having piggyback on the onclick method.

Also, make sure you clear your cache to make sure you are using the lastest update you did.
From what I read somewhere, IE requires the href link and the name of the window. Using the onclick seams to not bother the popup blockers.

My website

Thanks pan, I hadn’t tried that, but it doesn’t make any diffence:(

IE has a serious evil streak. it doesn’t seem to matter what I do, it just doesn’t want to work for me. I think I’ll just press on and tell people to use firefox:P

Thanks for all the help guys, I appreciate it!

Just a thought, but did you check the security options in IE and make sure javascript is enabled?

My website

You should end the “onclick” attribute with “;return false” so that the href URL doesn’t get activated in addition to the new window.

Opening new windows is considered annoying by many users.

– Dan

I know nothing about web design, but I want to load a jpeg onto a website that currently has nothing on it. can you explain how to load a jpeg up to a webpage?

Here’s a couple links. Please start a new thread in the future.