I need a newer version of DBD::mysql

software development

#1

I have attempted to install a newer version of the perl module DBD::mysql, but it fails the connectivity tests, and then it fails to install.

Ive tried using CPAN, as well as compiling the source. Can anyone help me figure out how to install this as non-root?

Thanks!


#2

Have you read/followed the DreamHost Wiki article on CPAN?

It specifically addresses “how to setup CPAN as a non root user,” describes the process on DreamHost, and has an “if you get an error” section. :wink:

–rlparker