I dont get outgoing mailservers


#1

okay, so I am totally a newb at this part of email. my incoming is my mail.mydotcom.com and the outgoing is smtp.isp.com or is it smtp.mydotcom.com ? I am at a friends house on wi-fi and I cant send an email, I always have used smtp.comcast.net, but I dont know what internet they have, and he doesnt even know if he pays for that. Nonetheless. I just wnat to be able to send an email :slight_smile: thanks for your help.


#2

If you are talking about using you DreamHost SMTP server, it is the same as your “incoming” IMAP/POP3 server: “mail.yourdomain.tld”. If you are wanting to use your ISP’s server, it will vary (and you have to get that information from them). Which one you choose to use is a matter of choice; you can use either.

If you are trying to set-up a client to use you DreamHost server via your friends connection, you may have to modify your port setup in your client if your friend’s ISP has blocked port 25 (See the DH wiki article on setting up email clients).

If his provider (ISP) is different than yours, you may also have to go through other steps to access your ISP’s server (some require specialized server addresses for “out of network” access, alternate client settings, etc - and some just don’t allow it.)

AT&T in particular requires some machinations to use their server from when not connected to the net via their system.

Don’t forget that, in a crunch, if you can’t immediately get the settings for your email client sorted on a new connection, you can always send via “webmail”, accessible at http://webmail.yourdomain.tld.

–rlparker


#3

I have tried to change my ourgoing as mail.mydomain.com and it did not work. Any thoughts?


#4

Well, as I mentioned in my first post, I suspect that your friend’s ISP may be blocking port 25, which will preclude you from successfully connecting to you DreamHost server at “mail.yourdomain.tld” untill you modify the client’s port setting (often using port 587 will work).

What email client are you trying to use, and what is the exact error message you receive when the attempt to connect fails?

–rlparker


#5

yea I tried that port 587. Here is my error. ( of course I cleaned it up some) "The server response was: jon@website.com: Recipient address rejected: Access denied

Use the pop-up menu below to try a different outgoing mail server. All messages will use this server until you quit Mail or change your network settings.

Message from: My name here surjones@mywebsite.com"

I also used poert 2525, which is what my chic uses at her work. :slight_smile: Did NOT work BTW


#6

Well, access denied is actually “progress”, as it indicates you are reaching the DH server (you are still trying to reach the DH server at mail.yourdomain.com instead of your ISP’s server, right?).

That indicates that there is just some problem with your settings. Unfortunately, I don not use “mail” so, I can’t give you a stroke for stroke, though I believe the wiki does.
'
Have you read through the DH wiki articles on configuring “mail”?

http://wiki.dreamhost.com/KB_/Email/Client-Specific_Setup/Mac_OS/Mac_OS_X#Apple_Mail.28aka._.22Mail_or_Mail.app.22.29

http://wiki.dreamhost.com/Mac_OS_X_Mail

–rlparker


#7

okay well I solved the problem, but changing the server port to 465 and SSL. Which requires me to accept this secure pop up window. every time I start Mail. "There may be a problem with the mail server or network. Check the settings for account “p” or try again.

The server error encountered was: Mail was unable to verify the identity of this server, which has a certificate issued to “*.mail.dreamhost.com”. The error was:

There is no root certificate for this server.

You might be connecting to a computer that is pretending to be “mail.allaboutnow.com”, and putting your confidential information at risk. Would you like to continue anyway?"

I can send emails, but the part that worries me is the at risk issues. so what do you think?


#8

just change the outgoing settings to:

smtp/outgoing mail server: mail.yourdomain.com
change the outgoing port to: 587
make sure you select “outgoing mail server requires authentication”. you got that error message because you didn’t have that set. in apple mail, click on preferences, select the accoutn and click on the “server settings” button. from there change the server port to 587 and for authentication select passwrod and enter in your login and password

use the wiki, it has all of your answers:
http://wiki.dreamhost.com/KB_/Email/_Client-Specific_Setup

–

johngrayson.com
suffocate[us]