I can't upload photos since the server change


Hi, I could use a little help.

My account was moved yesterday to a new server. I have 3 domains, they all use wordpress and they are all set up the same way. When uploading content via wordpress, it creates a new folder each month.

The problem is that today I can’t upload photos on two of my domains via wordpress. One works fine. The other two keep giving the error:

Unable to create directory /home/.dez/myusername/mydomain/wp-content/uploads/2009/09. Is its parent directory writable by the server?

Anyone know how I can fix this?



There is your clue! Your WordPress has the “dataglob” (that “.dez”) from the old server in the upload path setting, and since that it not on your new server, WordPress cannot create a directory under it!

The fix here is to go into the WordPress administrative back end, into the “Settings -> Miscellaneous” section, and reset the “Store Uploads in this folder” setting (Under “Uploading Files”) to the default value (“Default is wp-content/uploads”).

Save your changes and you should now be good to go.

–DreamHost Tech Support


Excellent, that worked. I knew it had something to do with .dez but was really unsure what to do.