I can't register domains


#1

Hi, I created a new account, and tried to hire a new shared hosting and new domains. However, the domain name registration won’t work for me. I fill in all the required fields, the panel tells me that he is registering the domain name, but then it won’t show the domain name as registered. I can even register it again. It won’t charge my account either for the domain names.

Thanks.


#2

My customer wants these websites to start working soon. I have submitted two support tickets five hours ago, but I still haven’t received any answer. What is the average answer time of the support service?

Thanks.


#3

Hi there!

I see your submitted support ticket and a tech will be investigating it shortly.
In the mean time I would like to see if maybe we can troubleshoot.
Can you explain the step you are taking while registerting a new domain and what kind of message you get after?
Also, what domain name you are trying to register. If you don’t feel comfortable posting it here, just email it to me.
Thanks!


#4

I sent you an email.


#5

Hi, 10 hours ago I registered 11 domain names, then they didn’t show up on my account. I sent a support ticket to you but you still haven’t answered it. Can you please tell me what is the problem?

Thanks.


#6

Please help me, my customer will be angry if I tell him that no domains have been registered yet. It’s been almost 24 hours since I tried to register the domain names!!


#7

I have tried to register the domain names again, changing the contact information. The same thing happens: nothing is showing on my control panel, and if I try to register the domains again, it shows they are available!!

Please please please please please help me!!


#8

I apologize for the delay! Our support team is looking into your ticket and will update you shortly (within minutes) with information regarding your domain issue. (I have made sure of this!) Thank you for your patience in this matter, it is appreciated.

Thanks,
Matt C


#9

I have submitted the form again, with the corrections that you submitted to me. However, the domain hasn’t been registered. The problem is still there!! It tells me the domain registration is pending for a few minutes, and then it tells me again it is available. So the solution that you provided is not correct.


#10

Hi davaguco, just wanted to follow up and make sure everything’s OK. Looking at your support history, it looks like you were able to get all your domains registered! Please don’t hesitate to let us know if you need any assistance again, we’ll be happy to help. :slight_smile:


#11

I was finally able to register all domains, it seems the TAX ID didn’t go through if I typed a slash on it (B-xxxxxxxxx instead of Bxxxxxxxx). Also, it didn’t like Limited Shareholder type of organization, I had to type Public Limited Company. I had to try A LOT of things until I came up with the right answer.