HTTP error on image upload

wordpress

#1

I’m receiving an http error when I try to use the wordpress media uploader. This is happening for JPG files that I’ve sized down to ~100kb.

Similar to this thread I found from a week or two ago:

Is there anything I can do to rule out a similar error cause?


#2

What is the HTTP Error code you are receiving?


#3

We had some ImageMagick issues after a recept upgrade. Is this still happening?

(sXi - if it’s the one I’m thinking of, it literally just says ‘HTTP Error’ and it’ll upload the file, but fail to make any thumbnails/resized images)


#4

Those informative error codes are the bestest :smiley:


#5

I have the same issue in my website and is still happening. As a photographer, this problem is very important for me and my business to be resolved. I tried by myself but I am unable to find any clues about what’s happening and where to start.

Please, anybody is still experiencing the issue?


#6

robotto - Did you open a ticket on this? There are a couple things we can check for you (like the temp folder being full).


#7

I think I’m in this boat too. Getting the “HTTP error” with media uploads. I can upload a single image, I can upload multiple images below a certain size/dimensions (about 500px wide), but I can’t upload multiple images of the size I usually use (610px wide). This causes many or most in that particular batch to stall and throws up multiple HTTP error notes.

Not sure if related, but I get a capacity error when I try to edit my large “functions.php” file through the WordPress editor. The rest of the PHPs, which are short, work fine.

Maybe a memory issue?


#8

Capactity error? I checked the /tmp folder on your two domains and they’re okay. But that you can upload most images, but not large ones, makes me think you’re running out of memory.

What is wp-memory-usage giving you? I see you have that activated.


#9

Hello,

my domain wp instance is www.saralazaro.com.
The memory report is:

PHP Version : 5.3.13 / 64Bit OS
Memory limit : 90 MByte
Memory usage : 33.06 MByte


#10

Eventually figured it out! For some reason PHP 5.3 FastCGI was causing the media uploader to flake out. Switching to 5.3 CGI fixed it. Maybe something about the optimization that causes this particular process to get wonky when it does more than a minimal amount of image crunching.

My memory plugin always read about 33-35MB, same as robotto.


#11

have the same issue. Changing PHP from FastCGI to CGI doesn’t work. Any suggestions?

[Wed Jun 05 09:16:07 2013] [error] [client 212.248.9.45] ModSecurity: Multipart parsing error: Multipart: writing to “/tmp/20130605-091607-Ua9kR0PNN00AADA76PEAAAAF-file-uLUTDR” failed [hostname “gameit.ru”] [uri “/wp-admin/media-new.php”] [unique_id “Ua9kR0PNN00AADA76PEAAAAF”]

[Wed Jun 05 09:16:08 2013] [error] [client 212.248.9.45] ModSecurity: Input filter: Failed writing 8192 bytes to temporary file (rc 18446744073709551615). [hostname “gameit.ru”] [uri “/wp-admin/media-new.php”] [unique_id “Ua9kR0PNN00AADA76PEAAAAF”]


#12

zombak - Open a support ticket please, your tmp folder is full :slight_smile:


#13

I am also getting an HTTP error. How can I fix this ASAP?


#14

I’m still getting the error on my site
CloudApp
is there any way to fix this?


#15

On all your sites or just one?

Also it looks like you solved it by changing to CGI (from FastCGI) for PHP… If I read that ticket right. Interesting!


#16

Hello. I’m receiving an HTTP error when I try to download images via WP (with OptimizePress). It just started out of nowhere. I have no clue what to do. Any advice? Thanks :slight_smile:


#17

JneNY - Try it now. If it keeps happening, open up a ticket. I saw that your tmp folder was pretty full, so I cleaned that out of some cruft for you.


#18

Hi,

The issue could be that you are running a localised version.
You will need to load WPLANG only for frontend, not for admin. Some plugins simply don’t work correct with localisation.

Check http://andreii.org/wordpress-multilanguage-simple-way/ and http://andreii.org/wordpress-jetpack-localisation/

This worked for me after two weeks of trying different tweaks.


#19

Hello, same problem here as thousand of people on Google, anybody has a definitive solution ? Thank you.


#20

@makeonlineshop: post the exact error because there is no definitive solution to a failure to write a temp file.