Http connection timing out


#1

UPDATE: Nevermind, it seems to be working now. Kinda flaky today though. Not the machine, just the http server.

Every time I try to hit my website with a browser it times out. However the machine pings and the traceroute is as follows:

traceroute to markearnest.net (66.33.217.108), 30 hops max, 40 byte packets
1 telecom9-fastethernet13-1.gw.psu.edu (146.186.110.193) 1.081 ms 0.662 ms 0.443 ms
2 gsr1-msm3-e2-1.cac.psu.edu (128.118.1.17) 0.426 ms 0.26 ms 0.378 ms
3 telecom1-gigabitethernet6-2.gw.psu.edu (192.168.1.133) 0.735 ms 0.467 ms 0.436 ms
4 bar-psu-i1-so-4-2-0-1.psc.net (192.88.115.189) 4.012 ms 10.383 ms 3.83 ms
5 minime-ge-0-1-0-0.3rox.net (192.88.115.5) 4.535 ms 4.325 ms 4.947 ms
6 pos4-1-1-0.a01.pitbpa05.us.ra.verio.net (199.239.216.13) 4.439 ms 4.321 ms 4.443 ms
7 ge-0-3-0-4.r01.pitbpa05.us.bb.verio.net (129.250.24.142) 4.684 ms 4.639 ms 4.41 ms
8 p16-1-1-2.r21.nycmny01.us.bb.verio.net (129.250.5.123) 16.491 ms 16.376 ms 19.844 ms
9 p16-7-0-0.r04.nycmny01.us.bb.verio.net (129.250.3.49) 16.173 ms 15.99 ms 16.336 ms
10 so-10-1.core2.newyork1.level3.net (209.244.160.149) 16.47 ms 16.077 ms 16.112 ms
11 ae-0-51.bbr1.newyork1.level3.net (64.159.17.1) 16.31 ms 18.854 ms 16.518 ms
12 so-0-0-0.bbr1.losangeles1.level3.net (64.159.1.157) 81.39 ms so-0-2-0.bbr2.losangeles1.level3.net (64.159.0.246) 77.501 ms so-0-0-0.bbr1.losangeles1.level3.net (64.159.1.157) 112.92 ms
13 so-10-0.ipcolo2.losangeles1.level3.net (4.68.113.162) 81.921 ms 82.263 ms so-11-0.ipcolo2.losangeles1.level3.net (4.68.96.62) 76.875 ms
14 ge1-l3.dreamhost.com (64.156.46.110) 82.715 ms 81.532 ms 82.581 ms
15 basic-linus.gloop.dreamhost.com (66.33.217.108) 86.867 ms 89.393 ms 86.134 ms

So everything looks ok, but it seems maybe apache crashed or something.