.Htaccess problems (500)


#1

I created my own .htaccess file with only “ErrorDocument 404 /index.php” and put it in the domain dir using the FTP program FileZilla.
It suddenly disapeard, so I created a new one in the same dir. Now I got a 500 Internal Server Problem, and it blamed my .htaccess. I deleted the .htaccess file, but I still get the error. Can the first one have laid itself some otherwhere? I’d rather not re-install the whole page.


#2

You might need to modify your Filezilla configuration.

See http://filezilla.sourceforge.net/documentation/remotefilelist.htm

""Always show hidden files

Some servers don’t show hidden files like dotfiles (filenames starting with a dot) by default. Enable Always show hidden files if you want to see those file. However, not all servers support these feature, they may return an error or may return broken or incomplete directory listings. So be careful when enabling this feature.""

Hope that works. In my FTP client, I get to specify the actually parameters instead of a simple checkbox, so can’t be sure if this is the same thing.

:cool: Perl / MySQL / HTML+CSS


#3

Thank you. Before I read your post, I tried to insert an empty .htaccess file which also disapeard.

I found it in the Logs dir, but now I dont have permission to delete it? Or is that another .htaccess that can screw up my whole website?


#4

Uh, yeah that would be a different .htaccess file. Generally files don’t magically appear somewhere else when uploading them by FTP. They should appear in the directory shown in the ‘Remote Site’ box. Each directory can have its own .htaccess file. And you can’t delete the ones in the logs directory because that is not “your” directory, its what DreamHost has setup to keep track of the log entries and statistics for your site. There is a way to log into see the statistics (http://example.com/stats) and and .htaccess file is used for that.

:cool: Perl / MySQL / HTML+CSS