.htaccess keeps disappearing/webftp forbidden


#1

Trying to upload a backup of a wordpress site, all files transfer fine except .htaccess won’t upload. In ftp it just disappears after refresh and through webftp I get an error saying ‘forbidden’.

Any thoughts? I don’t have extra web security selected and pretty much nothing seems to work.


#2

This is a limitation of dreamhosts webftp.

webftp won’t display hidden files (specifically those files where the name begins with a . ) I’ve found that I can upload a hidden file such as .htaccess via webftp but like you say it appears to disappear after it’s uploaded. It’s actually there it’s just that the webftp client will not show it.

If you use a local ftp client such as filezilla, fireftp (plugin for firefox), or winscp, etc. then the default settings will also most likely hide ‘hidden files’ and you will need to find the setting in preferences to ‘display hidden files’ and set it.


#3

Thanks a lot that worked great