Htaccess is invisible

apps

#1

Hello,

I’ve uploaded an “.htaccess” file to the ftp directory and though I can see my .htaccess on other hosts and have the ability to see invisible files in my client software (fetch on a macintosh) the files are not there in the dreamhost ftp window. Please tell me how to turn them to visible.

Thank you!


#2

They are always visible. The can only be invisible if either your FTP client or your operating system are hiding them.


si-blog | Keystone Websites
Save $97 on yearly plans with promo code [color=#CC0000]SCJESSEY97[/color]


#3

From what you have described, since you’re sure your client is displaying the “hidden .xxxxx” files, I can only assume the problem is likely to be:

  1. Which directory the file got uploaded to (you said “the ftp directory” - you might double check any directory in your user space :wink: )

  2. Could your ftp client be displaying a cached directory listing? (this often happens if you do not “refresh” the remote directory display with some clients).

–rlparker


#4

Hello,

I loggged in ftp.domainname.com

username
password

went to the alias www.domainname.com

put the files up there and refreshed as I always do. The mac os x always makes any files with a period invisible, however fetch doesn’t. In my previous host with the same fetch software in directory listing window, side by side, the .htaccess file is there, in the dreamhost window, it is not.

I’ve been working on web stuff for nearly 10 years now, and this is the first time that I couldn’t see a file with a period in front of it. It’s not on my end, is what I’m trying to say, essentially

Thanks, though for your prompt replies.


#5

I understand, and was not meaning to imply that you didn’t know what you were doing…just offering the only suggestions that I have found seem to help others. :wink:

I’m not familiar at all with fetch - I suggest you log into the shell via ssh and do a “ls -la” of the “www.domainname.tld” directory to see if it is really there.

That said, you prior host, unlike OS X, might not have set the “.” files to be “hidden”, which could account for what you are seeing with your FTP client (they won’t show in OS X, but will show in your client). DH does set them to be invisible, and your client will have to have it’s settings configured to display them) .

Have you double checked to make sure your ftp client settings are configured to show hidden files? (I know, you’ve been doing this for 10 years, so please don’t get ruffled at the suggestion)?

The only way to tell for sure if it is “on your end” or not is to look at the directory in the shell and list the hidden files - if it is there, then it is somehow related to your client. :wink:

–rlparker


#6

Will do.

I take no offense and sincerely appreciate your suggestions. I used to work with hardware installs and many times it’s the simplest things. I sometimes know what I’m doing, and other times I’m dain bramaged, so thanks and I will use the shell. I checked the fetch preferences early on and it’s configured to show invisibles, but I will double check. I’ve not been getting enough sleep lately, so I might have missed it.

I’ll keep this posted, is there a way to mark this post as solved once I get done?


#7

No problem, and hopefully you will get it sorted in good order. Sometimes these are the simplest of things but can be aggravating to figure out!

It is always helpful to other if you post how you solved the problem, and many people do that by just posting a reply to the thread with the “Subject” cahnged to reflect the “solved” status (for example, the subject in this thread could change to “Re: .htaccess is invisible [SOLVED]” or something). :wink:

–rlparker


#8

I can see the htaccess with the web ftp, but my ftp client doesn’t see the file with .periods in front, it’s not the settings in my ftp software, it’s the default way that dreamhost sets it up for better protection.

I forgot about this thread, that’s why it took so long.


#9

I’m using filezilla and can see .htaccess file when I enable the option to show hidden files.

Dino
Get YOUR $97 off on yearly plan with [color=#CC0000]YOUGET97 [/color] promo code. Sign Up NOW


#10

Yes, it is indeed the settings in your FTP client. If you tell us what client you’re using we can help you locate the options to show hidden files.

–Matttail
art.googlies.net - personal website


#11

mattail is correct. WIth Fetch how you accomplish this depends upon the version of fetch you are using. For “older” versions, the subject is addressed, and the fix provided, in this thread from the Fetch Message Board.

For newer versions (starting with 4.01):

Here’s how to view hidden files in Fetch:

1.) Go to Fetch’s Preferences.
2.) Select the Misc tab.
3.) Pick Obscure Options from the popup.
4.) Toggle 'Send LIST -al to UNIX servers.'
5.) Save. You may need to reconnect for the change to be effective.

Finally, a quick search of the Fetch Message Board provides an even later instruction from Fetch Softworks (March, 2007):

Assuming you’re trying to see them on the server:

  • Click Cancel to close the New Connection dialog, if necessary.
  • Choose Preferences from the Fetch menu
  • Click the Miscellaneous tab (in Fetch 4, click the Misc tab).
  • Make sure the “Omit filenames beginning with a period” checkbox is unchecked.
  • Close the Preferences.
  • Then connect to your server, or select the transfer window showing your files and choose View > Refresh (in Fetch 4, choose Directories > Refresh File List).

I’m thinking one of those should work for you! :wink:

–rlparker