.htaccess help


#1

I got the following email today:
“I’m writing you about your site. It is getting severely
DDOS’ed and is causing huge amounts of read/writes to the file server,
causing high loads on the entire cluster and effecting 1000’s of
customers. I’ve had to disable it for now, when you can work on this you
can remove the “deny from all” from .htaccess (or write us back and we
can do it), and immediately install the wp-cache plugin and enable it:”

The traffic surge is over, but I’m having trouble getting to my .htaccess file. I can’t see it in any of the directories when I connect with FTP.


#2

you must connect via telnet or ssh.


#3

Thanks, but how to I do that? I can use putty, but what to I use to connect?

It doesn’t let me log in with my FTP user name and password


#4

Sorry for the double post, but I really need to get my site up. So please? Anyone?


#5

Right, sounds like you don’t have shell access for that user.

2 ways to sort this:

  1. log into the dreamhost control panel and give your user shell + ftp access (in the users menu). Then dot he putty thing, find the .htaccess file in the domain.com folder, and edit it.

or 2) in your ftp app you may have a “show hidden” option. Don’t know what you’re using for ftp, but FileZilla has this option.

Either way will work.

Cheers,
Karl

web design, development & seo by DigitalVibe


#6

I’ve just got a “temporarily unavailable” message from the panel, so it looks like right now you’re limited to the ftp option.

If your ftp client doesn’t have “show hidden”, then FileZilla can be downloaded here

Cheers,
Karl

web design, development & seo by DigitalVibe


#7

Once you get your .htaccess sorted, don’t forget the last part of support’s message:

Or you will likely just find yourself disabled again when/if you get another traffic surge. :wink:

–rlparker


#8

Thanks guys. I got it working with WinSCP somehow, and I did install WP-Cache.

I was using FileZilla the whole time! I fell stupid now that I didn’t realize the .htaccess was hidden.

Anyways, thanks for your help!