.htaccess help please


#1

Hi,
I am sort of new at this so of course I messed it up.
I read all the files I could find here about using .htaccess with Dreamhost.
I opened a file on my Domain by just clicking on Go in the manage domain section. The folder was named .htaccess but there was nothing in it yet.
I opened Notepad and pasted in some of the information that I saw in the help sections. Then I also saved that as .htaccess but Office 2000 Word would only save it with the .txt extension.

Oh I set the permissions for the Folder as 644 like it was suggested.

Then I went to FTP over my text file but there was no .htaccess folder showing to FTP over to. So I went back into the Manage area on dreamhost control panel and into my domain. No .htaccess folder.

I tried to create a new one and I get an error popup that I do not have permission or some such thing.

How do I find this folder? I tried going into View and changing the hidden files to visible but nothing happened.

How badly did I mess this up?

I would appreciate any help I can get. Thanks.

Why don’t I have permissions on my own Hosting service? This is too odd.

Rocque


#2

G’day, Rocque.
Not sure about the folder named .htaccess… as far as I know:
a) .htaccess is a hidden file, not a folder (but I suppose one can name a folder as .htaccess).
b) to create a .htaccess file, use a plain text editor (e.g. Notepad)–never use M$Word!–save the file as htaccess.txt
c) upload the file in ASCII mode to the correct directory
d) then use your FTP client to rename the file to .htaccess
Note: the dot in .htaccess makes the file hidden. For your FTP client to see the file, you will need to set the client to display hidden/system files.
All the best,
marsbar


#3

Hi thanks for the quick reply.
I created a folder thinking that was what the help topic meant but then discovered I was supposed to not have a folder but a file.

I run Microsoft, so as I mentioned used Notepad and made the .htaccess.txt file.

I tried to FTP that over. It said the transfer was complete, however that file is not showing up anywhere. Not on the FTP area and not in Dreamhost.

I went into View on the menu bar in Dreamhost and set the folder/file options to show all files. I hoped to see the .htaccess file but nothing was there.

I guess I should get some sleep.

Thanks again for trying to help.


#4

I don’t know what FTP program you use, but I’d guess if you are using the standard FTP package built into explorer it won’t show hidden files. I’m not sure if you can change this, or if you are using a different FTP package, how to show hidden files. Tyy looking in your options.
I’d recommend using Smart FTP.


#5

Hi again,
Thanks decswxaqz for your help. I am now able to see my .htaccess file in the WS_FTP95 program that I use.
However it is still invisible when I go to my Dreamhosted ftp folder for my site.
Is that because it is a Microsoft product?
I have checked and rechecked my file view from there. Is it supposed to be invisible there?

Thanks again for everyone’s help. I am getting there. I know a lot more than I did last night.

Rocque


#6

Wow, all this help is absolutely awesome!
Now I know where to come for help.

Thanks so much. I think I have it sorted for now.
Rocque