.htaccess and .htpasswrd files DISAPPEAR!

software development

#1

Hi,

Thanks for your help.

I’ve attempted to upload .htpasswrd and .htaccess files to my site only to find that they’ve totally DISAPPEARED when I refresh the folder.

I’ve even attempted to rename them to something else such as test.txt, then change it to .htpasswrd (and did this for the .htaccess, too) and, after changing the filename,
it DISAPPEARED AGAIN!

Is there a work-around to this?
I NEED these files for My Scripts to work.

Thanks again in advance for your help.

:slight_smile:

FirstBorn


#2

Any file beginning with a ‘.’ is considered ‘hidden’ under Linux, the files are still there, you just won’t see them unless your FTP client is configured to show hidden files.

The exact procedure to enable this will vary from client to client, but the option should be in the client configuration somewhere.

Mark


Save [color=#CC0000]$50[/color] on DreamHost plans using [color=#CC0000]PRICESLASH[/color] promo code (Click for DreamHost promo code details)


#3

Hi Mark,

Thanks for responding.

Actually, I’m able to view this file at other webhosts,
but not on this one (DreamHost) for some reason.

I’m using WS_FTP (an older version.)

My Scripts are acting as if the file isn’t there.

Any ideas?

Thanks.

FirstBorn


#4

Look what pops up in google: http://blog.dreamhosters.com/kbase/index.cgi?area=2932

Was your previous hosts on UNIX/Linux systems?


$1 for me << [color=#00CC00]SE7ENOF9[/color] | [color=#CC0000]SE7ENOF97[/color] >> All for you


#5

[quote]I’m able to view this file at other webhosts,
but not on this one (DreamHost) for some reason.[/quote]
If the other hosts are not running Linux, then they may treat these ‘hidden’ files differently.

Somewhere in the configuration for WS_FTP you will see an option to enable the display of ‘hidden’ files.

You can confirm that this is the problem by logging in using the web-based FTP client, which is configured to show ‘hidden’ files by default. Using this client, you should be able to see the ‘hidden’ files.

Mark


Save [color=#CC0000]$50[/color] on DreamHost plans using [color=#CC0000]PRICESLASH[/color] promo code (Click for DreamHost promo code details)


#6

Hi Mark and Se7enOf9,

Thanks!

I ONLY USE Linux Hosts…

Well that’s New!
I was able to see the file in the webftp.

For some reason, I thought that .htaccess and .htpasswrd files were deleted automatically.
Whoda thunk that it would have been My FTP Program?!?

Now, I gotta go figure out why the scripts aren’t working properly now when they did on My Previous Host…
Drats! These issues are driving Me bonkers.

Thanks for All of Your Help!

FirstBorn


#7

If you have any problems working that out, start a new thread detailing the issues and I am sure someone here will be able to help you out.

Good luck.

Mark


Save [color=#CC0000]$50[/color] on DreamHost plans using [color=#CC0000]PRICESLASH[/color] promo code (Click for DreamHost promo code details)


#8

Hi Mark,

Thanks Again!

I probably will 'cause I keep getting an error and the scripts aren’t working properly when I had them set up perfectly at the previous host.
(Not knocking Dreamhost at all… I Still think that they’re Great.)

Since I was FINALLY Able to VIEW the files, I was able to CHMOD them properly for testing purposes.
STILL get the errors, so keep an eye out on My Next Thread.

By any chance, are You familiar with webmasterinabox.net’s scripts?
(That’s the scripts that I’m currently attempting to work with DreamHost’s Servers.)

FirstBorn


#9

Unfortunately not, but I just had a quick look and it appears that this package is a compilation of lots of smaller scripts.

If you detail exactly what you are trying to achieve and the problems that you are encountering, I am sure someone will be able to point you in the right direction.

Mark


Save [color=#CC0000]$50[/color] on DreamHost plans using [color=#CC0000]PRICESLASH[/color] promo code (Click for DreamHost promo code details)


#10

I am not at all familiar with the scripts you are talking about, but one thing to remember is that due to DH running CGI scripts as your user under suexec, you should not chmod executable scripts to anything other than 755 even if the instructions tell you differently (such as 666 or 777). If you do, the scripts will not work on DH.

–rlparker