How to upload files to the server

software development

#1

I’d like to let users upload files 10-20mb in size to the server. the upload_max_filesize for php is 7mb, which screws me over.

how can i get files 10-20mb to my servre? (cant use ftp)


#2

mm i saw the wiki article, except i dont know how to use shell :frowning:


#3

Just follow that wiki article. To use shell, I recommend PuTTy or you could use WinSCP which is based on PuTTy.

Check out Gordaen’s Knowledge, the blog, and the MR2 page.


#4

see the wiki article on SSH to learn how to access your shell.

–Matttail
art.googlies.net - personal website


#5

ok i followed the wiki article and i’m stuck at the

point.

i run the command i get

[quote][peso]$ ./php-update.sh
: command not foundne 6:
Unrecognized character \x91 at -e line 1.
./php-update.sh: line 8: s/.post_max_size./post_max_size: No such file or directory
: command not foundne 8:
./php-update.sh: line 9: s/.upload_max_filesize./upload_max_filesize: No such file or directory
: command not foundne 9:
./php-update.sh: line 10: : command not found
[/quote]
any ideas?


#6

I was able to use telnet to run the php installscript. However by default ssh is disabled and must be enabled via the web panel before you can use putty, telnet or other.
Silk


#7

yes, i enabled ssh and logged in succesfully.

tried this with telnet and got the same errors when i ran that command


#8

Ok, there is a step missing. It is in the php 5 install. I guess this is the php4 install instructions.
Anyways, log in via ssh and type:
vim php-update.sh (press enter)
Now take the script on the wiki, copy it to your clipboard, (paste it into your own word processor, if you need to edit the script, then copy to clipboard again) now in your ssh window, type i for insert, then rightclick and select paste.
Now hit escape, then :qw (press enter)
Finally chmod your script to allow it to execute.
chmod +x php-update.sh
Hopefully if I gave you the direction correctly you should beable to continue with the wiki directions.
Silk


#9

I was trying to follow the wiki page myself. There was an error in the code for “php-update.sh”. The 7th line on the page was:

The 10th (last) line was:

The last character of the 7th line and the first character of the 10th line was a ` character. (This is the character on the ~ key of your keyboard.) Instead it should be a ’ character (on the " key).
So the lines should be:

I have updated the wiki page to reflect this change. Make this change to your php-update.sh file and try again.

There is another mistake that I think I found on the wiki page related to the crontab command, but since I have no experience with crontab, I am hesitant to change it without some testing. To read about this issue, check out the discussion page on the wiki. I am doing some testing now. If it works I’ll edit that part of the wiki page as well, if someone else hasn’t changed it first.