How to start server?

I just opened a shared hosting account here in order to run a PHPbb forum that has been bogging down my main colo server. I’m a little confused about how to get the account to start serving http …

I am on slimy ( As far as I can tell, there is no httpd running (that IP does not respond on port 80). What do I need to do to start it?

There’s no instance of Apache running on the machine’s main IP. You don’t have to do anything though - our system works it all out.

If you’re trying to do something weird (like just point a subdomain to us), there are some workarounds you can use…

I am running my own DNS though. What IP should I be pointing my hostname to, then?

What I want is this:

I have a site which is running on another host at another hosting company.

I would like to host here in my account at Dreamhost.

I am running my own DNS (at Zoneedit). I have already set up to point to (slimy). However, does not respond on port 80, even though I have set it up as an active domain in the dreamhost control panel.

(The end goal is to have, not… but I need to get the test one running first before I try the forums one, as forums is an active site.)

The cleanest way to do this would be:

  1. Add a subdomain.
  2. Add a unique IP to it ($4.95/mo)
  3. make a CNAME to

Alternately, you can just lookup whatever hostname / domain you added via our authoritative nameservers and point the subdomain to that IP - however we make no promises that it won’t change.

I’m going to do the latter for now, but that still doesn’t solve the main problem, which is that that IP ( does not respond on port 80!

It’s not supposed to! As I said in my original response, there is no webserver bound to that IP address.

See my response to your support inquiry too.

Ok… then can you please tell me what IP I am supposed to point my A records to?

Once you’ve setup a domain or subdomain on your account, you can query our authoritative nameservers for the IP.



Non-authoritative answer:

Presumably is not the authoritative nameserver, then? What is the correct nameserver to use?

Ah, the IP seems to be (I found it through trial and error of all the ips reported by ifconfig…)

That just leaves mysql… doesn’t seem to be right.

The mysql hostname I added was, but without knowing what IP to point that to, that’s meaningless. Don’t tell me to query your DNS servers – your DNS servers aren’t authoritative for, and are just going to tell me whatever my DNS server tells them to tell me!

There are two problems here:

  1. It takes a little while after you add something for our nameservers to respond for it. You’d want to use ns(1,2,3)
  2. I need to do some magic inside our system to make and work properly. Note that if you try to add to our system ever in the future, it may cause some problems, so just be forewarned.

Now that I’ve done this, I think you can just add NS records for those subdomains to:

if you want to set that up for your other subdomain, let me know.

I’ll response in more detail to your support inquiry.

bangs self on head

I didn’t realize you wanted me to delegate DNS for the subdomains to your nameservers rather than me hardcoding the IPs for my subdomains myself.

That makes a lot of sense, now that I realize it…

Well it wasn’t my original thought, but considering what you’re trying to do, it’s probably the cleanest way to do it. It’s actually not working the way it should be - so hold off on that for a few until I get that figured out.

I’ll respond to your support message when I get it working.

Ok. I’ve set up the following at ZoneEdit: IN NS IN NS IN NS

I can’t set up the domain on my end until I am sure the test one is working. ( is extremely active, so I want to switch it in the middle of the night or something.)

So, please set it up as /if/ there are NS records like the above for - I will make the change tonight sometime.

In the meantime, for the purposes of testing, can you please tell me the IP of

meow% dig

; <<>> DiG 9.2.2 <<>>
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 29474
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 3, ADDITIONAL: 3

; IN A


;; AUTHORITY SECTION: 14400 IN NS 14400 IN NS 14400 IN NS

All set on the side. I can’t touch on my side until I’m confident everything works on the test side, because it’s in active use.

[dmd@eco ~]$ dig

; <<>> DiG 9.2.2-P2 <<>>
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 11515
;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 3, ADDITIONAL: 0

; IN A

;; AUTHORITY SECTION: 172800 IN NS 172800 IN NS 172800 IN NS

Now… what about mysql? I’ve created a mysql host, but it doesn’t seem to be in DNS…

Database: stuffztest / Size: KB
Service Type Setting Status Modify
stuffztest active [ Edit ] [ Delete ] changed [ Edit ] [ Deactivate ]

[stuffz@slimy ~]$ dig

; <<>> DiG 9.2.1 <<>>
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 30526
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

; IN A

;; AUTHORITY SECTION: 300 IN SOA 2004110500 16394 1800 1814400 300

;; Query time: 5 msec
;; WHEN: Fri Nov 5 14:45:44 2004
;; MSG SIZE rcvd: 103

NS records for are in place now… I stuck a simple php-based redirect to send people to the old site for the time being.