How to modify PHP.ini?


#1

Dears,
I need change PHP.ini Allow_call_time_pass_reference=Off into Allow_call_time_pass_reference=Off ON

How to do it?

Thanks!


#2

From the PHP Manual section on Language Options:

[quote]"allow_call_time_pass_reference boolean

Whether to enable the ability to force arguments to be passed by reference at function call time. This method is deprecated and is likely to be unsupported in future versions of PHP/Zend. The encouraged method of specifying which arguments should be passed by reference is in the function declaration. You’re encouraged to try and turn this option Off and make sure your scripts work properly with it in order to ensure they will work with future versions of the language (you will receive a warning each time you use this feature, and the argument will be passed by value instead of by reference). "[/quote]
If your application can use PHP4, you can simply set your domain to use PHP4 (from within the DreamHost control panel) and the Allow_call_time_pass_reference option will be set to “ON”.

That said, and to answer your actual question, there are two ways on DreamHost for you to edit php.ini to change certain lanuage options:

http://wiki.dreamhost.com/Custom_PHP.ini

http://wiki.dreamhost.com/Installing_PHP5 / http://wiki.dreamhost.com/Installing_PHP4.

You should note that neither of these methods is supported by DreamHost Technical Support staff; if you go this route you are “on your own”. :wink:

–rlparker


#3

There is one other approach you might consider, depending upon your application.

The default DreamHost PHP4 installation has Allow_call_time_pass_reference=ON; if you do not need to use PHP5, you can simply set your domain to use PHP4, and this issue will be resolved for you (at least until you can no longer use PHP4). :slight_smile:

–rlparker


#4

If your application can use PHP4, you can simply set your domain to use PHP4 (from within the DreamHost control panel) and the Allow_call_time_pass_reference option will be set to “ON”.


This is the best advice I have gotten to far and it really solved a problem that has been raging for 24 hours under 5 minutes. You Are GREAT!

Thanks man


#5

Ha ha! You are welcome and I’m glad you got it working! :slight_smile:

–rlparker