How to increase PHP memory?


#1

Hi. Apparently my PHP memory is set to 48MB, which is too low, I’m getting performance issues. How can I increase it and what is the optimum setting?


#2

How high you should set it depends on what you’re doing. Our default is 90M though.

You’ll want to make a custom PHP file: http://wiki.dreamhost.com/PHP.ini#phprc

Then you’ll increase your memory like this: http://wiki.dreamhost.com/PHP.ini#Increasing_the_PHP_Memory_Limit


#3

Apparently mine is set to 48MB. Are you able to increase it to 90MB for me?


#4

Generally this is something we let you do on your own, since it’s really all under yoru control.

That said, yours really is set to a memory_limit of 90. I did change that to 128 for you.

Where are you seeing 48?


#5

Hi,

I wanted to reply to this since it was helpful to me. Mine was set to 40 MB in wordpress, and a quick change in the wp-settings.php file fixed it. Perhaps jenbenn an install that limited it as well.

Thanks for your help Ipstenu!
-Andrew


#6

Are we talking about shared hosting here??? If so, can you hook me up with a bump up in the memory limit as well? :slight_smile:


#7

PHP memory is a funny thing… You CAN change it to 128M in your phprc, and in small bursts that’s okay (it won’t hit our process watcher). It’s useful for those moments when you’re uploading a large image once in a while. However… if you constantly need that level of PHP memory, every day, all day, then even if you change it, you’ll get a note about how you’re getting a bit big for your britches on shared :confused:

Generally I say that if you HAVE to have 128M all the time, it’s time for a VPS or DreamPress (depending on your install setup). Which sucks, cause a VPS is a lot more work and way beyond the ken of mortal men… unless they’re weird and want to quit bank work for web stuff…


#8

I set that in my [font=Courier]phprc[/font] some time ago, but I got the impression that it was still impossible to go over 90 MB. If it really does work for small bursts, then perfect. I don’t need more than 90, but when a spike hits, an extra 20-30 MB means another PHP instance can fit into my allocation and increase capacity since my app’s footprint is in the 15 MB range.


#9

Where do i go on the dream host section to enter these codes to increase the upload size etc
[hr]

hi andrew where did you go to make the changes , suffering from same issue myself


#10

You edit the file on your server, via SFTP or SSH.


#11

Hi,
I am having the same problem too, it shows 40MB on Wordpress, not sure how to increase it on wordpress. Understand the default for DH is 90MB, not sure why it is not shown on wordpress.

Thanks in advance for your help.

Jessica


#12

Hi Jessica, have you tried looking at the guide below?


#13

I just added

; {{{ The following lines were automatically added by DreamHost extension=xcache.so ; }}} That's all from DreamHost memory_limit = 256M

to my home/user/.php/5.4/phprc file but WooCommerce is still mentioning I am using 40MB. I added define( 'WP_MAX_MEMORY_LIMIT', '256M' ); before settings is loaded, but this setting also seem to be ignored in WooCommerce. BackupBuddy does indicate I am using 256M now. Any ideas why?
NB On a VPS


#14

Because you are on shared hosting.


#15

Never mind. Had to add define( 'WP_MEMORY_LIMIT', '256M' );
to WP Config to make WP use it all


#16

WP will try to use it all, but you’ll only be able to use 90MB before you get the following error:


#17

@bobocat, did you notice the very last line of post #13?


#18

Nope, because the context of posts #1#12 is a shared hosting environment. I’d blame OP for not picking the correct thread.


#19

Hello, I found this thread and hope I could get some help. I need to have my server configurations to…

max_execution_time = 300
max_input_time = 120
max_input_vars = 2000
memory_limit = 128M
post_max_size = 15M
upload_max_filesize = 15M

…for the theme that I purchased through my third part. I have tried updating my PHP through filzilla that way and it doesn’t see to have worked. Is there anyway you can help me out.

Thanks


#20

You set those values using a phprc file. This link tells you how: https://help.dreamhost.com/hc/en-us/articles/214894037-How-do-I-create-a-phprc-file-via-FTP-