How to FastCGI and CGI?

software development

#1

Hiii. I cannot activate fastcgi and cgi scripts on my hosting, and i am not sure how to done it:

1.- I enabled in my panel fastcgi support in Dreamhost
2.- I followed the wiki: http://wiki.dreamhost.com/PHP_FastCGI but:
I create php5-wrapper.fcgi in /home/myuser/ and in /home/myuser/magarto.com/ (i do not know where i have to put it, sorry)
I made it executable.
I have added next to .htacces at the top of the .htaccess of Wordpress blog (home/myuser/magarto.com/blog/ ) which i want to use fastcgi:

AddHandler fastcgi-script fcg fcgi fpl
AddHandler php5-fastcgi .php
Action php5-fastcgi /php5-wrapper.fcgi

Also i have added next to the top of my .htaccess in the top of my server: i mean /home/myuser/

Options +ExecCGI

And, i have always 500 internal server error.

Thanks a lot and sorry for the inconvenience, but i need it and i have enable other .cgi scripts

Thanks


#2

I have exactly this error, but i don not know how to solve it:


#3

What worked for me was making sure the path in this line

Action php5-fastcgi /php5-wrapper.fcgi

was relative to the web root. So, php5-wrapper.fcgi should be in /yoursite.com/, not in your home directory.