How to edit php.ini?


#1

hello all,
I have installed Owncloud on my dreamhost account.
all is fine but I need to edit the php.ini so I can increase the max upload size.
I have followed the instructions here http://wiki.dreamhost.com/index.php/PHP.ini and pretty sure i got it correct but everytime I turn it on with the .htaccess file, I get this

I also tried the SXi’s Easy Auto Copy Script, mentioned on the same page - which leads to the exact same error.

Being that im getting the same error, manually and with the script leads me to beleive its not what I doing…how is this typically done?


#2

It looks as though the instructions you used may have inadvertently switched your domain to PHP 5.2. ownCloud requires PHP 5.3 or later.

Follow the steps laid out here for making php.ini customizations for PHP 5.3 or 5.4: http://wiki.dreamhost.com/index.php/PHP.ini#PHP_5.3_.2F_5.4


#3

Wiki needs an extra quick edit.

When using PHP 5.4 you’ll need to create the file /home/[user]/.php/5.4/phprc


#4

well, the edit page of the domain config says 5.3 with fastcgi…is there someway to get it out of sync with waht is choosen here?
[hr]
$ php -v
PHP 5.2.17 (cli) (built: Mar 1 2012 16:36:14)
Copyright © 1997-2010 The PHP Group
Zend Engine v2.2.0, Copyright © 1998-2010 Zend Technologies
with Zend Extension Manager v1.2.2, Copyright © 2003-2007, by Zend Technologies
with Zend Optimizer v3.3.9, Copyright © 1998-2009, by Zend Technologies

how do I get php5.3?


#5

The settings in Manage Domains only affect the web server. The command line is not affected; the “php” command will always give you PHP 5.2 (for now).

If you want PHP 5.3 on the command line, ask for it by name: “php-5.3”.


#6

ok, so if I have 5.3 selected…and owncloud still says I do not have 5.3…what do I do?


#7

Look in your .htaccess file for directives pointing to a custom dispatcher and remove them if found.


#8

I got it, trashed the domain and started fresh…works like a charm!
thank you for the help!