How to "drop the tables"


#1

I am trying to do a clean install of Wordpress. The first time I installed to a subdomain but it never picked up. (maybe you have to install to a root first??) Then I tried to do a new install of Wordpress to the root but could not complete the install because there was already a directory there. SO I went into mySQL to delete the database and I get this message:


Want to empty the recycle bin?
It can take 30 or more days for a database to be removed automatically from your MySQL Recycle Bin.

However, to destroy all the data in your database, you can always connect to it directly (with PhpMyAdmin, from the command line, via a script, etc…) and drop all the tables.

If you want to re-use the name of a database that’s in the recycle bin, just restore it, drop the tables, and go!

My question is: how do I “just restore it, drop the tables, and go!” I have never used PhpMyAdmin before. Any help would be much appreciated!


#2

[color=#808000]Panel > Goodies > MySQLDatabases[/color]

  • If you actually did delete your DataBase, click on the Recycle Bin and restore it.

Once restored, go back to the previous page (or if you didn’t delete it)…

  • Click the phpMyAdmin link that’s next to your Hostname up the top.

  • Use the USER and PASS that is set up for that particular DataBase’s access.

  • In PHPMyAdmin, select the DataBase, Check all Tables, and Drop them.

Log out of PHPMyAdmin and reinstall WP :slight_smile:


#3

Thank you Very much for your willingness to help me. Your instructions are clear to follow, but are not working for me. I’m sure I must have done something wrong, so I will try to explain as clearly as you have.

This is what my MySQL database pages looks like: http://cl.ly/2A1k2c0y0G1c073m3T1r

I was able to restore the test1pds_info database. It is the test1pds.info domain that I am trying to install on. When I go to click the phpMyAdmin link at the top, next to the hostname, it sends me to a generic GoDaddy page instead of a prompting for a username or password, like this: http://cl.ly/252C0n0A3U250r24351k
I also tried with with /CAStest at the end, thinking perhaps that was the issue, like so: http://cl.ly/1S2w3F393h0Z011v310r

What step am I missing here? Is there an alternate way to access the phpMyAdmin dashboard?


#4

Looks to be a DNS issue.

Click on one of the other links to PHPMyAdmin to get in :wink:


#5

There are no tables in that database to drop: http://cl.ly/3i3x3G1D0B331z390z3F

But it is present on this screen: http://cl.ly/3K2U2u202b082b233K02

can you help me figure out what to do next?


#6

To connect to that you would use the following info:

db server: mysql.kathrynprice.info
db name: test1pds_info
db user: test1pdsinfo
db pass: [password]


#7

Yes, I’ve connected, to the test1pds_info database, but it says there are no tables to drop. Yet they still appear in my panel & I cannot make a wordpress install as the system thinks there folder is not empty.

This is what the myPHPAmin screen looks like:
http://cl.ly/3i3x3G1D0B331z390z3F

thank you for your patience with me!


#8

There are no Tables to drop because that database is empty :wink:

Ensure you are inputting the same details into the WP installation form.


#9

Also “folder is not empty” is not the same thing as “database not empty” Folder not empty means a directory on the server.


#10

I just tried to install and I got this message,

"We were unable to set up wordpress as requested at:
http://www.test1pds.info/

The problem was directory /home/katieprice/test1pds.info is not empty! Please re-install, specifying an empty (or new) directory.

Please correct this and go to our web panel and re-submit your
wordpress installation request."

But I thought we just determined it was empty. Hmm… any ideas on what I could be doing wrong?


#11

I just tried to install and I got this message,

"We were unable to set up wordpress as requested at:
http://www.test1pds.info/

The problem was directory /home/katieprice/test1pds.info is not empty! Please re-install, specifying an empty (or new) directory.

Please correct this and go to our web panel and re-submit your
wordpress installation request."

But I thought we just determined it was empty. Hmm… any ideas on what I could be doing wrong?


#12

could it be the other attempts to create a database? I attempted 3 other times that never installed. Should I restore those & try to delete those through phpMyAdmin?


#13

The folder be referenced by /home/katieprice/test1pds.info is a directory on your web server. It has nothing to do with your mysql database.

You need to use FTP/SFTP or your shell to delete the contents of that directory on your web server (not database, these are different).

Unrelated to your current issue: your domain test1pds.info currently is pointing to godaddy and not dreamhost.


#14

Thank you for chiming in! I deleted everything inside the test1pds.info directory via FTP.

I thought I had set the nameservers set to Dreamhost, but obviously they weren’t, so I just updated that as well. Do I have to wait for that to populate? Or can I try a new install now?


#15

if you have changed the nameservers it would be simplest to wait for DNS propagation to reach you. You can actually go ahead and do the install at anytime, however it would be best to wait until you are sure you can complete the second half of the install at the same time, which means waiting for DNS propagation.

The other option of using a mirrored domain is more complicated than this situation calls for.


#16

Naming domain path, sqlhost, and users with very similar patterns will often lead to confusion.


#17

It worked! The part I was missing was clearing the directory via FTP.

Thank you!