How to configure mail filter to block all EU mail?


#1

I have been slammed with spam lately, as many people have been. All the mail from domains ending in .eu are spam. I get NO legit mail from anyone with that address. I set up a filter to delete all .EU mail, I thought, but it doesn’t work. Filter says that all mail with FROM @.eu should be deleted. Does nothing that I can tell. Is there another way to configure this? My spam from .eu addresses is increasing radically, and while it all ends up in my quarantine folder, I do occasionally get real mail there and hate sorting through all that junk daily. Many thanks.


#2

In the dreamhost panel on the manage filters page, I would add a new filter. “From contains .eu” and click the “Delete it” radio button. You can do the same thing by logging in with email credentials at https://mailboxes.yourdomain.com


#3

I have tried FROM contains *.eu and .eu. I am still getting mail from .eu addresses. With filters to delete mail with *.eu, .eu, and @.eu, I just got junk from Keena@wealthoughlc.eu

So, those options to delete mail from .eu do not work. Any other ideas? Thanks


#4

The only hint I can give is the filters at the location that I gave don’t need or want any wildcards or @'s just put .eu

Changes made to filters via the panel or mailboxes won’t take effect for about 20-30 minutes. (perhaps a few minutes longer than what it says)


#5

.eu was the first thing I tried several days ago. Still getting them. Thanks for the response.


#6

I’d open a ticket with support and ask what’s wrong.


#7

Answer from Dreamhost is that the filters do not effect the quarantined mail. Not at all helpful in reducing the spam I have to sort through.

They said:
Thanks for contacting DreamHost. Sorry to hear about the issues with mail. The way our mail filtering system works is that mail goes through the anti-spam filter first then if it is not deemed spam according the quarantine/tag levels it is passed to the message filtering server (known as procmail). In this case the message filtering never receives the message because it gets placed into the quarantine first, thus ending its trip. If you do not like mail going to quarantine you can disable spam filtering and just use message filtering to handle all your mail. Another option would be to raise your quarantine level to be less restrictive allowing more spam to get through finally allowing the message filtering server to work on those emails that were once quarantines. Default is set to 4 so we recommend doing it one point at a time.


#8

This part doesn’t make sense to me. You’re getting these in your inbox, correct? If that is the case, then they are not ending there trip quarantined as spam.