How to change the memory limit with Web PS


#1

Hi, everyone:
I am a freshman in using Dreamhost Web PS.
My site is a Drupal 6.17 website.I tried to raise the memory limit of my site by pay for Web PS, and adjusted the resource bar in panel to 512mb. But nothing better happened.

I asked the service man, a letter came back and told me I need to changed the php.ini through SSH and VI. I am not familiar with this skill, but it’s ok for me to find instructions for this.

After I done everything, the website still got nothing better. The php info shown that the memory limit is 90mb as usual. I wrote a letter again, but got nothing useful back(basically, DH won’t provide such detail instruction).

Now I am stuck here. Any suggestion or reference?


#2

sXi’s script is what I use for modifying PHP.ini settings:
http://sxi.sabrextreme.com/dh-phpini


#3

Hi, sdayman, thank you for your reply.
I install the dh-phpini, and I can change the memory limit by myself.

But things goes complicated. Even I raised the limit to 300mb, and resource chart shows the usage of my site lower than this number, it seems my site would run out the memory in a short time till it stop response anymore.

I can’t fix this except I reboot the server. It turn out I have to keep reboot my website to make it work well. It’s terrible!

How can I fix this problem?


#4

How much memory does your PS have allocated to it? If you’ve only got the minimum of 300 MB, then trying to let PHP use all of it will end very badly indeed (because there’s more than just PHP running on your PS — you also need a web server, for instance!).

Even if you do have more than 300 MB, the web server will often try to start up more than one PHP process if all existing ones are busy. As a rule of thumb, you should have at least enough memory for three or so PHP processes.