How to avoid WordPress login redirect?

wordpress

#1

When I moved my site to DreamHost, I somehow got the idea it should be installed on a subdomain (hgchicago.dreamhosters.com) first, then, when it appeared to be working properly, copied over to my main domain (hgchicago.org). So that’s what I did.

Now, if one goes to hgchicago.org, the site seems to work. Most of the internal links go to hgchicago.dreamhosters.com, but some go to hgchicago.org. This is troubling but I can eventually fix it.

More seriously, I cannot login to hgchicago.org/wp-admin. That gets redirected to hgchicago.dreamhosters.com/wp-admin… Somewhere there must be a setting that causes this, but so far I’ve not found it and I’m hesitant to go mucking randomly around in the WordPress files. I need know where it might be. (I assume it’s in WordPress; could it be something DreamHost did?) Suggestions?


#2

If you log into your wp control panel and go to settings => general are BOTH Wordpress Address (URL) and Site Address (URL) changed to hgchicago.org?


#3

Well, no, of course it never occurred to me to look there.
All fixed! Magic!! Thanks Ryo-ohki.