How do I publish to dreamhost?

wordpress

#1

Wordpress installed on Dreamhost, built the first page, how the heck do I get it up on Dreamhost? I clicked “Publish”, I go to my URL and just get the “there ain’t no page here yet” screen


#2

It looks like you partly installed WP in a subfolder called WordPress (note the capitalization).

When I go to your domain, it acts as if I’m logged in as you and that is caused by the index.html file.

You should do the following:

  1. Delete the index.html file

  2. Copy (do not move) the index.php and .htaccess files from the WordPress folder into the main folder of your site.

  3. Open your root directory’s index.php file in a text editor

  4. Change the following and save the file. Change the line that says:

to the following, using your directory name for the WordPress core files:

  1. Login to your site. It should still be http://example.com/WordPress/wp-admin/ :slight_smile:

  2. Go to Settings -> Permalinks and press save (that will re-set your permalinks)

That should be it :slight_smile: If that doesn’t get it fully working, let us know, or ask one of our awesome support folks for a hand.


#3

OK, I did what I could. I can’t find the .htaccess file, but I changed the code in the index.php file in Dreamweaver. When I go to my site I’m still logged in automatically. I thought WP was supposed to be easy to work with?


#4

It is easy :wink: You’re actually doing something a little complicated. Normally people just install WordPress in the main location (i.e. example.com). You sort of did it in a weird halfway manner too.

What you’re doing is what we call Giving WordPress it’s own directory and yes, it’s confusing. But the good news is you’re almost there!

Go to yourdomain.com/WordPress/wp-admin/options-general.php

You should have the following settings:
WordPress Address (URL): http://yourdomain.com/WordPress/
Site Address (URL): http://yourdomain.com

Now you said you don’t have a .htaccess, that’s okay! :smiley: Go to yourdomain.com/WordPress/wp-admin/options-permalink.php and press ‘save’


#5

Sorry, but I did a one-click installation, so WordPress got installed wherever it directed itself. So now that I have the URL problem sorted out, how do I get WordPress to publish there? Will it just do this on it’s own? Thanks for the help!
[hr]
OK, it publishes all right, but it still shows me logged in as soon as the page opens. What now?


#6

It’s okay! You’re supposed to be logged in. But now, when I look at it, I don’t see that I’m logged in :smiley:

If you log out, or look at your site in a different browser, you will see your site, perfect :slight_smile: And may I say that is a killer mustache?