How do I configure gem so that Passenger can see RoR?

apps

#1

I’m having trouble deploying my RoR app (Redmine). This worked fine on ‘etch’. We upgraded yesterday to ‘squeeze’ and this hasn’t been working since. All the information I can think of giving is below. I’ve tried different things but it seems that the fundamental issue is that calling gem rails isn’t doing what it is supposed to be doing. I’d love some help here. Thanks!

You can go here to see the error: https://dradis.ootbdev.com/

Avery

The error:

Here’s my gems env:

[code]ootbdv[01:19 AM]~ (0.04 Mb)> gem env
RubyGems Environment:

  • RUBYGEMS VERSION: 1.3.7
  • RUBY VERSION: 1.8.7 (2010-08-16 patchlevel 302) [x86_64-linux]
  • INSTALLATION DIRECTORY: /home/ootbdv/.gems/
  • RUBY EXECUTABLE: /usr/bin/ruby1.8
  • EXECUTABLE DIRECTORY: /home/ootbdv/.gems/bin
  • RUBYGEMS PLATFORMS:
    • ruby
    • x86_64-linux
  • GEM PATHS:
    • /home/ootbdv/.gems/
    • /usr/lib/ruby/gems/1.8
  • GEM CONFIGURATION:
    • :update_sources => true
    • :verbose => true
    • :benchmark => false
    • :backtrace => false
    • :bulk_threshold => 1000
  • REMOTE SOURCES:

In my environment.rb I have these lines (3-8):

# Uncomment below to force Rails into production mode when
# you don't control web/app server and can't set it the proper way
# ENV['RAILS_ENV'] ||= 'production'

# Specifies gem version of Rails to use when vendor/rails is not present
RAILS_GEM_VERSION = '2.3.11' unless defined? RAILS_GEM_VERSION

I have already installed rails in all the appropriate places:

ootbdv[01:24 AM]~ (0.04 Mb)> ls ~/.gems/gems
actionmailer-2.3.11/  actionpack-3.1.0/     activerecord-3.1.0/     activesupport-2.3.11/  bcrypt-ruby-3.0.1/  hike-1.2.1/  multi_json-1.0.3/  rack-mount-0.8.3/  [b]rails-2.3.11/ [/b]   rdoc-3.9.4/       tzinfo-0.3.30/
actionmailer-3.1.0/   activemodel-3.1.0/    activeresource-2.3.11/  activesupport-3.1.0/   builder-3.0.0/      i18n-0.4.2/  rack-1.3.4/        rack-ssl-1.3.2/    rails-3.1.0/     sprockets-2.0.2/
actionpack-2.3.11/    activerecord-2.3.11/  activeresource-3.1.0/   arel-2.2.1/            erubis-2.7.0/       mail-2.3.0/  rack-cache-1.0.3/  rack-test-0.6.1/   railties-3.1.0/  tilt-1.3.3/

It looks like boot.rb is choking here:

    def load_rails_gem
      if version = self.class.gem_version
        gem 'rails', version
      else
        gem 'rails'
      end
    rescue Gem::LoadError => load_error
      $stderr.puts %(Missing the Rails #{version} gem. Please `gem install -v=#{version} rails`, update your RAILS_GEM_VERSION setting in config/environment.rb for the Rails version you do have installed, or comment out RAILS_GEM_VERSION to use the l\
atest version installed)
      exit 1
    end

#2

Hey, just curious if you were able to fix this (I’m having the same issue). Any input appreciated!

Thx
-Steve


#3

I think Dreamhost upgraded their Rails version as my redmine broke as well. I can’t even rake any more. Is rake no longer installed?


#4

I can’t even get Redmine working on a subdomain on my site. I’ve been pulling my hair out and DreamHost hasn’t been much of a help yet.