Hosting at Dreamhost with domain elsewhere


#1

This question has been asked many times before but I can’t find a full answer to the issue.

I have registered a domain name at 123-reg.co.uk. I want to host the website on my Dreamhost account. How do I get them to play nice?

I have changed the nameservers on 123-reg to ns1.dreamhost.com, ns2.dreamhost.com and ns3.dreamhost.com but what do I do now? In Dreamhost’s Web panel, I have tried adding a new domain but it won’t allow me to “Fully host” saying that "You can’t add that domain: you don’t have permission to add "

Any ideas?


#2

use a third party WHOIS lookup and see what the name servers say, I usually use http://www.networksolutions.com/whois/index.jsp and scroll down into the domain information and towards the bottom of the section you can see the nameserver listings.

Then try dreamhost’s WHOIS service: http://whois.dreamhost.com/whois.cgi Dreamhosts service won’t return info however if the nameservers are pointed elsewhere.[hr]
Also if you post back with followup info also give us your domain name please.


#3

What I think is relevant from the WHOIS service:

[quote] Relevant dates:
Registered on: 05-Jul-2011
Renewal date: 05-Jul-2013
Last updated: 08-Jul-2011

Registration status:
    Registration request being processed.

Name servers:
    ns1.dreamhost.com
    ns2.dreamhost.com
    ns3.dreamhost.com [/quote]

So the name servers seem right, but registration is still being processed? It’s been 5 days so that seems odd (or is it?)

The domain is kveducation.co.uk

Thanks!


#4

That’s just the weird status reports from Nominet. Don’t worry the domain is registered OKay as far as they are concerned.
If you run your domain through intodns.com it reports every thing is OK apart from a missing A record for your domain.
I can’t see why the control panel wont let you add that domain as fully hosted. I have lots of UK domains that are set up just the same way and they went in fine. I would raise a ticket with support.


#5

I agree, open a support ticket. The nameserver appear correct from several 3rd party points that I just checked.

Dreamhost’s own whois server needs to be updated!! For starters, why not just allow lookup for all domains, instead of limiting it to dreamhosts domains? Also it apparently hasn’t been updated recently becasue the error for your domain is “Please enter a .com/net/org/info domain name!”


#6

I’m having the same struggle. I have the name servers at www.jhstuartassociates.com pointed to dreamhost and the WHOIS lookup confirms that. But now what? Where do I go from the dreamhost panel? I’ve clicked all over the place and am feeling totally lost.

I hope I didn’t do this incorrectly. I already created a WP site on a subdirectory (www.js.alexisdubief.com) but the domain I want to use is hosted at GoDaddy and my friend (who I’m doing this for) wanted to leave it there. My goal is to take the WP site I created (a whopping 4 pages) and make it www.jhstuartassociates.com.

Advice? Thanks!
Alexis


#7

The assumption is that you don’t want to just redirect the new URL to the old URL, which is absolutely the simplest method.

I believe you can do this another way in about several steps provided you don’t get any errors along the way.

The basic steps are:
1- confirm the nameserver setting using dreamhosts whois service whois.dreamhost.com
2- add the new domain to your account as fully hosted with the exact same user as the the other. The dreamhost installer robot will go drop a domainname.com directoy in the home directory of that user.
3- if the user is not a shell user, then upgrade it to shell access
4- next in wordpress admin make the changes to the admin panel for the domain name, you will get an error message because your new info doesn’t match the files on the server, ignore the error but just make sure you have the info correct.
5- go to you shell account and move (rename) directories around
mv domainA.com temp.holder
mv domainB.com domainA.com
mv temp.holder domainB.com

that should swap the site you created onto the new url leaving the old url once again with an empty site.

There is probably a third choice using redirect and htaccess, but i’m not and htaccess expert so I will let someone else explain that if it exists.[hr]
PS - Step 4 has to be done before step 5. If you try to do step 5 first you will have to undo it because you won’t be able to access the site or the WP admin.


#8

I fumbled around and came up with an uglier solution but wanted to say I appreciated your thoughtful response to my struggles!

Alexis