Horde install problem

apps

#1

howdy

a zillion times, i have tried installing horde according to the instructions
in the wiki (http://wiki.dreamhost.com/index.php/Horde). i get very close and then slam into a wall. everything seems to go smoothly until i get to part 7, which sends me into mysql. i successfully get into mysql with the right passwords and databases and hosts and blah blah blah. but then when i run

source create.mysql.sql;

i get told i don’t have the right GRANT permissions blah blah blah,
and crash and burn.

so i do some research on grant and it looks like i can’t grant myself
the permissions that i need granted to me.

i then queried the dreamhost staff; they told me to ask here.

regardless, something is definitely missing with the wiki on a horde
install.

i had been successful with an install of drupal, so while i’m
certainly no superstar, perhaps that suggests that i can usually slog
my way through.

can anyone help? anyone happen to have an all-inclusive install script for horde with pear etc?

i really want horde because of its advanced multi-account email serving and its calendaring. plus it seems like the KDE desktop is trying to integrate with it.

best wishes

blahblah


#2

Hi, did you ever get this problem resolved?? I am at this exact step and don’t know what to do to resolve it.

Any advice you can offer is much appreciated!!
Jenny


#3

I had that same problem, so I just removed the GRANT lines from the .sql file and used phpMyAdmin (accessible from the MySQL management page in the panel) to import the new .sql file into the already-created horde database. Let me know if this helps or if you need more explanation!

Here’s my SQL file:

USE horde;

CREATE TABLE horde_users (
user_uid VARCHAR(255) NOT NULL,
user_pass VARCHAR(255) NOT NULL,

PRIMARY KEY (user_uid)
);

CREATE TABLE horde_prefs (
pref_uid VARCHAR(200) NOT NULL,
pref_scope VARCHAR(16) NOT NULL DEFAULT ‘’,
pref_name VARCHAR(32) NOT NULL,
pref_value LONGTEXT NULL,

PRIMARY KEY (pref_uid, pref_scope, pref_name)
);

CREATE TABLE horde_datatree (
datatree_id INT NOT NULL,
group_uid VARCHAR(255) NOT NULL,
user_uid VARCHAR(255) NOT NULL,
datatree_name VARCHAR(255) NOT NULL,
datatree_parents VARCHAR(255) NOT NULL,
datatree_order INT,
datatree_data TEXT,
datatree_serialized SMALLINT DEFAULT 0 NOT NULL,
datatree_updated TIMESTAMP,

PRIMARY KEY (datatree_id)
);

CREATE INDEX datatree_datatree_name_idx ON horde_datatree (datatree_name);
CREATE INDEX datatree_group_idx ON horde_datatree (group_uid);
CREATE INDEX datatree_user_idx ON horde_datatree (user_uid);
CREATE INDEX datatree_serialized_idx ON horde_datatree (datatree_serialized);

CREATE TABLE horde_datatree_attributes (
datatree_id INT NOT NULL,
attribute_name VARCHAR(255) NOT NULL,
attribute_key VARCHAR(255) DEFAULT ‘’ NOT NULL,
attribute_value TEXT
);

CREATE INDEX datatree_attribute_idx ON horde_datatree_attributes (datatree_id);
CREATE INDEX datatree_attribute_name_idx ON horde_datatree_attributes (attribute_name);
CREATE INDEX datatree_attribute_key_idx ON horde_datatree_attributes (attribute_key);

CREATE TABLE horde_tokens (
token_address VARCHAR(100) NOT NULL,
token_id VARCHAR(32) NOT NULL,
token_timestamp BIGINT NOT NULL,

PRIMARY KEY (token_address, token_id)
);

CREATE TABLE horde_vfs (
vfs_id BIGINT NOT NULL,
vfs_type SMALLINT NOT NULL,
vfs_path VARCHAR(255) NOT NULL,
vfs_name VARCHAR(255) NOT NULL,
vfs_modified BIGINT NOT NULL,
vfs_owner VARCHAR(255) NOT NULL,
vfs_data LONGBLOB,

PRIMARY KEY (vfs_id)
);

CREATE INDEX vfs_path_idx ON horde_vfs (vfs_path);
CREATE INDEX vfs_name_idx ON horde_vfs (vfs_name);


#4

Thanks very much for the suggestion, which I finally got around to attempting. God, I wish dreamhost would make a one-click install for either Horde or Egroupware. I am surprised it’s not so big of a priority. I would think it is.

Anyway. I tried your suggestion but ran into a wall again. I’m probably doing something dumb. If you are feeling generous and willing to help, email me off list at pom47zi02 / at / sneakemail [dot] com.

(That’s a disposable email address to avoid spam.)

Best wishes, and, again, thanks so much for the suggestion.