Hmmm...Ascii anyone? (Webpage problem)



I have several domains with Dreamhost and something odd is happening.
At random, literally, if I go to or (haven’t tested my other two domains), at any given time from work, the page will 1/2 load up-- 1/2 correctly and the other half is a garbled mix of ASCII characters…

What’s up with that?
Why is this happening?
I have no odd code in my HTML code.



what browser are you using? i’ve had this problem sometimes with mozilla… i think it may have to do with mod_gzip (which we use by default). i haven’t had this happen much recently, but i haven’t tried it recently either.

if this happens and you do a [shift]-reload in your browser, does that fix the problem?

FWIW, i wasn’t able to (easily) reproduce this with mozilla 9.8 on FreeBSD…


I’ve been having really strange results with the version of mod_gzip on egon too. Because all my traffic goes through a proxy (Squid, in fact) for some reason sometimes the gzip headers gets scrapped from the page and therefore the browser is trying to download the page as it was a gzip file. Very annoying… Still don’t get why it should be doing this, though. Is the mod_gzip the latest version?


Web Developer


you actually do have a few oddities in your code. If you’re using IE on windows then that’s probably not the problem.


I have oddities? Like what?



slappy% dpkg -l | grep mod_gzip
ii ndn-apache-mod Apache mod_gzip module

and in the source:

/* ====================================================================

  • MOD_GZIP.C - Version

Looks like that’s the most recent version at:


Hm :-\ Interesting… look at the following page, at the messages subject “MSIE downloading instead of rendering”


Web Developer


yeah… that looks like a different problem though… and in that case it’s related to a messed up proxy server, no?

raven: what browser(s) do you notice the problem in (and what version / OS)? can you reproduce the problem on a different browser / platform?


Yes, which seems strange as Squid is probably the most popular proxy out there. It doesn’t seem to handle HTTP1.1 header properly.

Anyway, what is the quick way to turn off mod_gzip for specific folders on my DHservers? Anything I can drop in a .htaccess file?


Web Developer


i’m not sure you’re able to override it in .htaccess, although it’s possible (if you contact support they can doublecheck for you). we can override it for you on a per domain basis for sure though.


OK. I’ll contact support and get that done, I’ll then monitor my bandwidth closely. I’ll need to look at the tradeoff between the extra bandwidth and the lost guys behind proxies.



Web Developer