Help with session save path


How do I get the “session save path” writable on Dreamhost with Joomla?


I’ve installed joomla several times on Dreamhost, and never encountered this problem. Told help us help you, could you please provide a little more information:

  1. Did you use the 1-click install or install yourself?

  2. Are you using PHP-CGI, MOD-PHP, or your own compiled php (and if so, what version, moddules, etc. - maybe include phpinfo output)?

3)What version of Joomla are you trying to install (latest “stable” is 1.0.3)

There is preesently a discussion on that talks about this situation,
(;prev_next=prev ) but that user was running in safe mode, and that should not be the case in any default DH directory configuration. I’m also a little leery of some of the advice in the thread, so why don’t we start troubleshooting with the above questions.


Hey mate,
Thanks so much for your reply…I am using the one-click install for Joomla 1.0.3 that Dreamhost offers. To be honest I am just a newbie with Mambo and all this database talk is definitely a steep learning curve for me!
I have successfully installed Joomla twice now but because the session save path is unwritable I cannot log into admin whatsoever, it just loops.
When I installed my MSQL DB I assigned it to PHP CGI I think because Dreamhost recommends this for stronger security etc.
From what I can gather this session save path might be something that has to be done from Dreamhosts side?
I have made a “tmp” folder in both the root directory and inside the administrator folder but this did not fix the problem :frowning:
Thank you again for your assistance I really appreciate it…are you having the same problems with Dreamhost?


Well, this is puzzleing, as I just did a new “one-click” install of my own to duplicate your problem, and had no problems.

In all of my joomla installs (ver 1.0 - ver 1.03), including the last “test” one that I just completed, the session_save directory is set as “/tmp”, which is a directory immediatly off the root of your server. It is owned by DH, and is, by default, writable by all users. You should not have to add any directory for that, and Joomla has always used that directory sucessfully for me.

We are gonna have to dig into this a little more:

  1. Since you used the one-click install, did you notice the directory was unwriteable at install time (when following the links provided in the “success” email sent from DH) or are you responding to an error message?

  2. what server are you on?

Question 2 is important, because it is about the only “difference” between our installs - both were done with the “opne-click” installer on DH. I suppose it is possible that your server is mis-configured in some way, though that seems unlikely as any DH server with an unwritable “tmp” directory would probably have caused all kinds of support requests by now.

  1. can you include the url of your “broken” installation, so I can visit and have a look?

Don’t get discouraged; Joomla works great on DH, and we will get this figured out.



That is frustrating that it works perfectly for others and I just can’t get it going :frowning:
When you ask which server I would be on would this be:
The url is:
I have deleted the directory right now but I will re-install it all again for you tonight so you can see the admin loop etc.
I have emailed support but I haven’t received any assistance in regards to this matter as yet.
I am happy to hear that it will eventually work and I am extremely appreciative of your assistance…you are very kind:)
Thanks mate,


Got a reply from Dreamhost support…here is what they have to say:
I think you should try turning php-cgi off for your domain as the variable you are referring to is set as following for domains running non php-cgi : php.ini.generated:session.save_path = /tmp

How would I go about this? Do I need to wipe everything I have and reinstall the MSQL DB as Apache instead of PHP-CGI?


Well, I hate to go against what DH Support tells you, but I think they missed the boat on this on. ALL my domians running Joomla, including the "test* that I set up this morning run PHP-CGI. In fact, if you use the “one-click” install (which I did this morning to test your circumstances), it tells you on the web panel that your domain will be set to PHP-CGI for the one-click install.

I think the next thing I would do would be to run a small php program from my home directory, while the domain is set to use PHP-CGI, to get the PHP information.

Simply put the following single line of code in a text file, name it “phpinfo.php”, then place it in your root web directory of your domain:

<?php phpinfo(); ?>

THen “run” that program by going with your browser to This will run a program that will show you all kinds of useful stuff about PHP as it is running on your server, and that will help us figure out what is going on here.

In all my domains, running on PHP-CGI, phpinfo shows that session.save_path is set to /tmp which is writable on all my servers.

I suppose it is possible that your server is misconfigured on the DH end, though I believe that to be unlikely. I am assuming that you are running PHP 4 as PHP-CGI, on a “standard” configuration DH server…the output of this program will confirm all of that, or indicate any deviation.

I personally suspect that you may have a stuck cookie or a browser cacheing problem, which seems to me to be more likely to cause a looping condition at login.



I just went to the url you provided, and got a “temporarily unavailable message” with a code “2”, which generally means your MySQL connection has failed.

This could be due to DH “rebooting” MySQL werver, a flaky MySQL server, or a configuration problem. If it is a temporary thing it should be up soon. I will check again lateer tonight or early this morning (0100 hours local time for me right now :slight_smile:



Got the PHP info script going…just not too sure about what it all means :wink:
The only thing I can think of where I might have gone wrong is that I selected PHP 5 instead of PHP 4 in the install I think? This is also shown in the php.ini file from the info script.
Maybe this is the problem?


The session save path is set to tmp according to the script!
I have no idea what is going on?
Am I missing something on the Joomla install maybe?


All my sucessful installations use the default PHP 4 PHP-CGI, so I strongly suspect that using PHP5 is the problem. I’m not sure where you “selected” php 5…in the Joomla install (I don’t recall seeing it there, but if I did I would have chosen PHP4 as that’s how all my domains are configured), in setting up your domain (again, I’ve not seen that, as I have been with dreamhost since long before PHP5 was available, and have used only the DH PHP 4), or in “some other setting”.

My advice is:

  1. clear your directory.
  2. Make sure you are using the default PHP-CGI PHP4 on your domain (Control Panel, etc.)
  3. wait till everything is reset
  4. reinstall the “one-click” Joomla, or “manually” install the newest Joomla 1.04 (security fixes) if the “one-click” is still using 1.03
  5. Enjoy.

I suppose there is always the chance that something might still be wrong, but the process I described is what worked “like a charm” for me yesterday when I did it to test for your problem.

There are some compatibility issues with Joomla with PHP 5, especially if you have not compiled your own at DH. To use Joomla fully, you do not need PHP 5.



You might want to check out this thread…looks like DH PHP5 might not be quite “ready for prime time” for most users :wink:



It was just a matter of switching back to PHP4 in the domain name settings.
I have successfully logged into the sites admin section now and I am so relieved.
I need to now try and upload my Mambo site over the top of Joomla or maybe I will just use Joomla with my sites template. I haven’t built the site as yet so maybe this will be the best option.
Thanks heaps for all your support, I couldn’t have done it without you :slight_smile:

Kind regards,


Congratulations! I’m glad you got it working. One caution, though, is that I strongly advise against your trying to “upload my Mambo site over the top of Joomla”. You are liable to creat a whole slew of problems that way.

The templates should be interchangable, with only the slightest (usually, none at all!) changes between Mambo and Joomla, and the Joomla code is considerably better debugged then the Mambo code.

Since the site isn’t built yet, I think you should just build it in Joomla (there is no better way to learn to enjoy the power of Joomla CMS than to play with it!).



Template worked fine so I am not even going to torture myself by trying to overwrite Joomla with Mambo…so not up for that!
Will I be able to enable SEF by changing the htaccess file?
At the moment I am just thankful it’s running, all the rest will work itself out in the end I guess :wink:


Yes, all you have to do is enable the SEF in the Joomla Site Configuration section of the backend, and rename the htaccess,txt file to .htaccess and you are good to go!

THe site looks nice and, I think, I managed to get to be the first registered user… WooHoo!



LOL…thanks mate :wink:
I really love Mambo/Joomla…it sure beats messing around with a HTML editor then having to upload the files.
It took me weeks to get a grasp of Mambo but now the light has turned on and I feel like I am on my way to conquering it at last!
What are your websites? I like to check out what other people are doing with Mambo.


I’ve done a bunch… several with Mambo, and now Joomla. Some have since been “taken over” by my clients (which was, to me, the whole point of Mambo/Joomla) and, subsequently, have gotten “a little rough around the edges” (or maybe “dog-earred” is a better term :wink: since they took over populating them and doing some dastardly bad things with the content (remember when the secretary in the 80’s discovered fonts - OMG!) but here a couple of “typical” sites I’ve built for clients: - pro bono

and an older one that the client has definately “made his own” :wink:

my own site is currently suffering from the old “the cobbler’s children have no shoes” syndrome…hasn’t been updated in yearsand now really reflects badly on my work. I’ve just been building stuff for clients. I really need to re-do mine, but I don’t have the money to hire myself! he he he…



I am in the same boat as you with my very first website, I haven’t updated it for well over a year now! I will just scrap it and replace it with a Joomla site :wink:
Your latest Joomla sites look great…is web design your full-time job?
I see what you mean about your clients handy work…the great thing about Mambo is it is so easy for the client to take over the site…so you gotta love that!


Thanks for your kind remarks…I *don’t" consider myself a “designer”, but I do develop websites, and provide other internet and IS systems consulting and training on a “full-time” basis.

I agree with you that “you gotta love” giving the small business user the ability to control their content, and Joomla/Mambo (and other CMS systems) make that a reasonable proposition for the “little guy” that can’t afford to have a “webmaster” make all the little mods, changes, addition, deletions, that are part of operating a site. Frankly, very few of my clients can really afford to pay me, or anyone other than the $10 and hour High School kid, or “off-shore and out-sourced” third world coders to do that kind of work.

I just try to give them a servicable, attractive, and well-architected site (and initial training) and let them take it from there. Some do better than others, and others who can afford it have me maintain it. Ultimately, it gives the client the ability to balance their budget with the quality of their site, and seems to work out, either way, well enough.

Doesn’t leave an impressive portfolio of stylish “cutting edge” or innovative sites to show off…but it pays the bills.