Help with Oscommerce and php.ini

apps

#1

Hi guys,
I hope someone can help me. I have an old version of Oscommerce running. When Dreamhost recently upgraded the shared server I’m on to PHP5, it “broke” the installation. When I navigate to the site, it just shows this error:
“FATAL ERROR: register_globals is disabled in php.ini, please enable it!”

I tried all of the steps on this page:

For a single domain, and it’s not working. Does anyone know what I might have done wrong? I know the best solution is just to upgrade OSC, but that will take me some time and I want the site to work in the meantime. Please help!

thank you


#2

Upgrade OSCommerce now. If it’s an old enough version that it’s asking for register_globals to be enabled, it’s likely to be vulnerable to a number of serious security issues, and is dangerous to have running on your site.