Help with cname


#1

So I’m having some trouble getting a cname redirect to work. I set up a subdomain like “store.mysite.com”, and I want it to point to a Yahoo! Merchant store I’m setting up. These are the instructions I received from Yahoo:


If you wish to have the hostname “store.yourname.com” point to your Yahoo! Store, you must have the following line in your DNS zone file for “yourname.com”:

store.yourname.com. IN CNAME accountname.site.yahoo.net.

Where “accountname” is your Yahoo! Store accountname. (Note: the ‘dots’ in the above line are important.)

All righty, seems easy enough. So I go to the DNS section for my subdomain, and put the “accountname.site.yahoo.net” (with my account name) into the Value field. I assume this is correct. When I try to add the record, I get this error:

“You already have a record for this name. you can’t have a CNAME and any other record on the same name.”

So what should I do here? This is a new subdomain so I haven’t messed with any settings on it. I’d really appreciate any help.


#2

Did you put “store” in the Name field? Is it possible that you already have a DNS record defined for store.mysite.com?


#3

No, I didn’t put anything in the Name field. Under the field it says “(leave blank for just ‘store.mysite.com’)” which is what I want, so I left it blank.

I don’t know how there would already be a DNS record defined for it. I just made the subdomain specifically for this. However at the bottom of the page it does list 3 records under the “Non-editable DreamHost DNS records For store.mysite.com.” section.

store
ftp.store
www.store

… all of Type A. Is this the problem?


#4

That’s the problem. When you created the subdomain, DH had to create DNS records for “store.mysite.com”. What you want to do is remove the subdomain and edit the DNS records for “mysite.com” to add a CNAME that maps “store” to the Yahoo hostname.


#5

Heeey, that makes sense. I’ll give that a whirl. Thanks a bunch.


#6

Hmm, well I deleted the subdomain but the three records for store.mysite.com are still listed for my domain. So I’m still unable to do this. =\