HELP! WebFTP is not wnough for me anymore


#1

Hello, I don’t have too much experience aside from one webdesign class I took about two years ago…
my problem is that I have used Webftp until now but now I need to upload bigger files and for this I need to use another FTP program. I have SmartFTP and Dreamweaver CS3 and I can’t make it work! (my webpage is : www.mekatronicsolutions.com)
so on Dreamweaver I went to Site>new site > advanced > remote info> and I selected FTP access for the ftp host I entered my webpage: mekatronicsolutions.com
as host directory : /mekatronicsolutions.com/test/
(I can choose any folder on the domain right?)
then I entered my user and password which are the same that I’ve been using with Webftp
and i try to test the connection but I get an error
here a screen of the error:
http://mekatronicsolutions.com/test/error.JPG

I used SmartFTP but I cannot connect either:

“[18:45:22] An established connection was aborted by the software in your host machine.
[18:45:22] Cannot login waiting to retry (30s)…
[18:45:22] Server closed connection”

then I tried with passive FTP but it doesn’t work either

I really need help I don’t understand what is the problem webftp works!
I know I probably did something wrong, can anyone help me?
thanks in advance to anyone that reads my post.

-Elkin


win xp pro sp2
dreamweaver cs3
SmartFTP
nod32
*no firewall
verizon FIOS


#2

When you use regular FTP, I think you have to specify the full path to the directory and not one relative to the web directory of your site.

So in your case you’d use:
/home/{yourusername}/mekatronicsolutions.com/test/

Free unique IP and $67 off with promo code [color=#CC0000]FLENSFREEIP67[/color] or use [color=#CC0000]FLENS97[/color] for $97 off. Click here for more options


#3

I use Dreamweaver also. On the Remote Info page you need the following information. Be sure to click Test – typos can be very frustrating.

for FTP host: {DH server name}.dreamhost.com
Host directory: /{domaine name}/
Login: {user name}
Password: {password for user name}


#4

I tried it, but it didn’t work :expressionless:


#5

Didn’t work :S

this is the error screen:
[img=http://img217.imageshack.us/img217/7775/untitledap8.th.jpg]

I’m not sure if is something to do with my host directory…


#6

The root directory for regular FTP access is the user home directory.

This means in in the FTP client / maps to /home/username (and thus you cannot change the current working directory to one belonging to another user)

This does not apply to SFTP. However in SFTP /home/username is a link to /home/.glob/username - they are interchangable.

:cool: openvein.org -//- One-time [color=#6600CC]$50.00 discount[/color] on [color=#0000CC]DreamHost[/color] plans: Use ATROPOS7


#7

Whooops. I guess I’ve been using SFTP for too long! Truth be told, I’m afraid to even log in using FTP since “The Incident”.

Free unique IP and $67 off with promo code [color=#CC0000]FLENSFREEIP67[/color] or use [color=#CC0000]FLENS97[/color] for $97 off. Click here for more options


#8

Hmm. That error message doesn’t fill me with confidence - that is, a “cannot connect to host” error seems to indicate something other than a password or directory problem, but rather a connection problem. I know you posted this in your original request, but i didn’t actually see your screenshot until now.

Since you’re on WinXP, what do you get when you try a command line ftp connection?

I know you say you don’t have a firewall, but the signs point to a network connection issue or, as a long shot, a problem with the userid you’re using to log in. Say, is your Windows firewall enabled?

BTW, apologies for my earlier screwup. After we get everything squared away, perhaps we can discuss using SFTP instead of FTP. It’s more secure!

Free unique IP and $67 off with promo code [color=#CC0000]FLENSFREEIP67[/color] or use [color=#CC0000]FLENS97[/color] for $97 off. Click here for more options


#9

Man your eyes are a lot better than mine! I couldn’t read any of the error message text at all.

One other thing he might try is trying connecting to his server instead of his domain name. As long as his user name/password is correct, he should end up in the same place, but if he can’t do that either it is a pretty good indication that he has some “local” connectivity issue.

Just a thought…

–rlparker


#10

In his second screenshot I do see that the OP tried connecting to merkur.dreamhost.com instead of his domain. Apparently the same problem…

BTW Bob, don’t forget to click on the screendumps to expand to full size. I dunno if your browser is configured similarly to mine buy I couldn’t read any of the text either until I clicked to expand the pic.

Free unique IP and $67 off with promo code [color=#CC0000]FLENSFREEIP67[/color] or use [color=#CC0000]FLENS97[/color] for $97 off. Click here for more options


#11

Yikes! That’s a good point and I’m grateful for the reminder - with my “old school” ways I often forget to do that. Thanks! :slight_smile:

–rlparker


#12

OK I figure it out… it looked as it was something with my computer so I tried to disable all firewalls and open the port 21 on my router but it didn’t seem to work…
So I put everything as it was before but i turned off my router for about a minute and guess what!? when I turn it on and tried again it worked!!
thank you very much for your responses!
~now back to work! :smiley:


#13

\o/ Yay!

Free unique IP and $67 off with promo code [color=#CC0000]FLENSFREEIP67[/color] or use [color=#CC0000]FLENS97[/color] for $97 off. Click here for more options