Help to wipe site for new wordpress install


#1

Dear all,

Thank you for considering my plea for help.

For some time I operated a blog at my url at the /blog address. It was at this same address that I installed wordpress.

I now want to install word press at the root site as the full website not just the blog.

I have backed up the blog contents and thought to then delete and reinstall wordpress at the root. When I try to do this I cannot seem to delete the previous folders on the site and when I try the one-click install at the root of my site I have the fault that word press cannot install as follows:

The problem was directory /home/XXX/www.XXX.com is not empty! Please re-install, specifying an empty (or new) directory.

Any tips on how I can clear out the directory to start afresh?

All help is very welcome!

Thank you,

Ky Nichol


#2

If you go to the one-click installer - https://panel.dreamhost.com/index.cgi?tree=goodies.installer& - and click on ‘Manage Installed Applications’ then you can see all your installed apps. If you expand them, you’ll see a ‘delete all files’ options. Click that and it will delete all the files in that folder.

Be careful! If you have anything else in that folder, it nukes that too!


#3

Thanks for the suggestion. I have tried that and the folders are still there. In the ‘Manage Installed Applications’ area there is no reference to the site I am attempting to amend?? I can however still see the folders using FTP.

All help gratefully received thanks.


#4

Are you familiar with SSH? If so, you can login through SSH and run the commands:

Meaning you would want to use something like /home/username/yourdomain.com/

If not, lemme know. If you want, you can also PM me and send me an email through your support panel and I can remove the files you need.


#5

Hi Voeltz thank you for your kind offer. I tried to PM you but got the message that I am restricted from doing that? The site of mine that I want to wipe and start afresh is www.kynichol.com. I have backed up all the files on the site and am happy that you remove all other files from that domain so I can start the wordpress install afresh.

Thanks,

Ky


#6

I am trying to do this same thing!


#7

Hi, if its not possible to do this via PM can you let me know how to use SSH - I have not heard of it previously - all help is very much appreciated - I am stuck!

Thanks,

Ky


#8

Just login via SFTP and delete the files.


#9

Tried that… downloaded WinSCP and attempted to delete the files. No luck got a ‘permission denied’ on the first java script file that it encountered.

Any other thoughts?

I am using the correct user name and password provided that should have the rights to do this.


#10

What are the permissions of the file and the directory the file is in? What user is listed as the owner of both file and its directory?


#11

kynichol - There are two folders out there on that domain, blog.old and blog.old2

I moved them both out to /home/user/www.kynichol.com.old so they’re out of the way but available if you want them back.

The permissions and ownerships were actually fine, which is very strange. I downloaded the files locally to see if anything jumped out, but it all looks normal.