Help! Spam Blacklist not working

apps

#1

Hi there,
I’ve tried installing the Spam Blacklist extension as explained at http://www.mediawiki.org/wiki/Extension:SpamBlacklist. I have downloaded the latest PHP files and saved them to a “SpamBlacklist” folder in my extensions directory. I have also included the following code in my LocalSettings.php file:

require_once( “$IP/extensions/SpamBlacklist/SpamBlacklist.php” );

However, when I go to my wiki site, I receive three error messages:

Warning: Call-time pass-by-reference has been deprecated; If you would like to pass it by reference, modify the declaration of runtime function name. If you would like to enable call-time pass-by-reference, you can set allow_call_time_pass_reference to true in your INI file. in /home/.whoopi/username/mywebsite.com/wiki/extensions/SpamBlacklist/SpamBlacklist.php on line 103

Warning: Call-time pass-by-reference has been deprecated; If you would like to pass it by reference, modify the declaration of runtime function name. If you would like to enable call-time pass-by-reference, you can set allow_call_time_pass_reference to true in your INI file. in /home/.whoopi/username/mywebsite.com/wiki/extensions/SpamBlacklist/SpamBlacklist.php on line 112

Warning: Call-time pass-by-reference has been deprecated; If you would like to pass it by reference, modify the declaration of runtime function name. If you would like to enable call-time pass-by-reference, you can set allow_call_time_pass_reference to true in your INI file. in /home/.whoopi/username/mywebsite.com/wiki/extensions/SpamBlacklist/SpamBlacklist.php on line 112

Does anyone know what this means? Please keep in mind that I have a somewhat limited knowledge of code…

Thank you.


#2

There seems to be a suggested workaround for you here:

http://www.mediawiki.org/wiki/Extension_talk:SpamBlacklist#Line_Error_Message

I have not tested this “fix”, but the poster there says using the version linked in that section solved his problem. :wink:

–rlparker


#3

Thanks, Rlparker!!! It works great. Now if I can only figure out the “bad behavior” function…


#4

Your are welcome, and I’m glad that you were able to get the one problem sorted.

As a suggestion for your other issue, I found that first solution using the error message(s) and the term MediaWiki in Google - maybe the same approach will produce a result for your Bad Behavior troubles? :wink:

–rlparker