Help please?

I have an error after I installed a script to run an Amazon Affiliate store on my site.

A friend sent me this since I know nothing about programming:

I wanted to make sure this wasn’t a problem with the install that affected me as well. If it did, I could just pass along the info you needed.

However, I installed the new 5.0.0 (non beta) version tonight and all went well. I do not get the error you have.

I did some research on the error. The file the error is generating from is func_global.php . The function is download_xml() and the line of code is:

IF($handle = @fopen ($url, ‘r’))

This if statement takes one path (downloads the amazon xml) if true. If false, it goes on to generate the error you are experiencing. So your server is having issues in using the fopen php function. In which case, I would not be able to fix this. You might want to take these two steps:

  1. Ask your host provider if there is anything they are aware of that would prevent an fopen() php call from executing on your server.

  2. Send email to GS advising of the problem with the fopen() function and ask them to provide an alternative function. GS noted on their site yesterday that they added two additional support reps to handle support, so I’m hoping they will start helping people out!

has anyone run into this?

At DreamHost, the allow_url_fopen directive (in php.ini) has been disabled for security reasons. I’m almost completely certain that your script is not running properly because of this. For more information about the problem, and how to go about resolving it, look at this page on the DreamHost wiki. You should be able to overcome the problem by using cURL.

Simon Jessey
Keystone Websites | si-blog

I’d wager that’s exactly the problem. I ran into the url_fopen issue when trying to install a plugin for wordpress here on dreamhost – I had to rewrite the open call to use sockets instead.