Help, please! Weird error message prevents upload


#1

Hi, first time here, hope someone can help.
Never encountered trouble before over several years of file uploads / file deletes, nor as recently as a few days ago, but I’m utterly flummoxed right now.

Opened FTP same as always, noticed odd pop-up stating:
[color=#FF0000]PARSING ERROR:
Invalid at the top level of the document[/color]

It did not prevent my deletion of some old obsolete files.

Upon trying to upload a new file, however – the “Links” page for my site – the upload window balked and produced this message:
[color=#0000CD]There has been an IO Error: <?xml version="1.0" encoding="UTF-8"?>
mkdir() [function.mkdir]:
Too many links in /home/webftp_dh/webftp.dreamhost.com/core/classes/class.AJXP_Utils.php (l.1029)[/color]

This is all well beyond my rudimentary skill level.
I retried uploading, got the same result, logged out, logged back in, tried uploading again, got the same result, logged out, tried a different browser,
logged in, tried uploading there, got the same result again. Removed some links from Links page, tried again to upload it, and still the same bad result.
Tried uploading a small (10kb) .jpg image and got the same “Too many links” error message with that as well.

I was quite certain I’m using, in total, barely a small fraction of my allotted dreamhosters storage.

Can someone tell me what’s going on and how to resolve this?


#2

Looks like you are using webftp from one of the paths listed in the error message.

My advice would be to upgrade to a full ftp client installed on your computer. For security I would set that up to use SFTP rather than ftp. Then in the dreamhost panel I would “disallow ftp” logins


#3

Thanks – the problem seems to have vanished as mysteriously as it had first appeared. Problems plural, actually – further attempts to upload
after posting here yielded not only the bad results described in this thread, but also those described in the topics posted by others this past week
(titled “FTP Server showing ‘parsing error’” and “HELP!!! my FTP logs in and gives me No Repository For This User”).

Several hours later, fresh attempts to upload encountered no warnings, no error messages, no problems whatsoever. Seeing as others had met with
similar or related difficulties, I’m guessing something was remedied by Dreamhost techs.