HELP! Moved blog between DH accounts - its dead!

wordpress

#1

Hi, I’m not really a technical kind of person, so I hope someone will be able to offer some advice to the pickle I’m in (i’m waiting for a Dreamhost support response to my request for help sent last night but I guess it might not come until after the weekend?)

Well, I moved my Wordpress blog from one Dreamhost account to another. Before doing so I contacted Dreamhost support and asked for step by step advice of how to do so. They provided it, and I followed it - backing up all files to my hard drive, exporting the MySQL database, deleting the domain from the old Dreamhost account, creating it in the new Dreamhost account, uploading the backed up files, creating a MySQL database with the sam name/username/password, importing the old database dump, and waiting a little while.

But it doesn’t work. I get this error message when trying to access my website in the browser:

"Warning: require(/home/.paulina/sitename/www.sitename.com/wp-content/advanced-cache.php) [function.require]: failed to open stream: No such file or directory in /home/.paulina/sitename/www.sitename.com/wp-settings.php on line 69

Fatal error: require() [function.require]: Failed opening required ‘/home/.paulina/sitename/www.sitename.com/wp-content/advanced-cache.php’ (include_path=’.:/usr/local/php5/lib/php’) in /home/.paulina/sitename/www.sitename.com/wp-settings.php on line 69"

When I try to access the direct path of an image I had uploaded previously, that does work, so I know that the files copied across and are acessable.

I am getting a little worried because although it has only been down for about 15 hours now, I have already had one website email me to say they have removed their link to me because my site appears to have gone. Not good news! I am panicking a little…

Any help will be GREATLY appreciated.

Thanks.


#2

do you actually have these two files at specified paths?


#3

Thanks for the response and the prompt to get me looking into the right things Nixus (even though, as I say, I am a technical novice)

First off, I am a little confused by the “/home/.paulina/sitename/www.sitename.com/” path - all I can see in my ftp is “root/www.sitename.com/” - what (or who!) is .paulina, and could that have something to do with the problem?

Apart from that, I can find the the file “www.sitename.com/wp-settings.php”, and on line 69 it reads:

“require (ABSPATH . ‘wp-content/advanced-cache.php’);”

BUT, and I guess this could be the real problem - I CANNOT FIND the file “www.sitename.com/wp-content/advanced-cache.php”. All I can find there are a bunch of folder, the index.php file and a wp-cache-config.php file, which seems close to advanced-cache.php, but no cigar!

The thing is, I downloaded and re-uploaded all the files that were there before - I didn’t do this with individual files and folders (would have taken too long), instead I just downloaded the folder www.sitename.com in the root as a whole, with all its contents coming with it. Could this file somehow have slipped through the gaps? If so, what can I do?

I also downloaded the other two folders in the root alongside the www.sitename.com folder, which were called “logs” and “Maildir”, just in case they were needed, but I didnt think that they were, so I have not uploaded them to the new hosting account to overwrite the ones that were created there. Could that have something to do with the problem?


#4

Hello,

I am doing almost the exact same thing as you, moving a Wordpress site from one DH account to another. I also got the same instructions from DH as you as far as backing up deleting, starting the new account, uploading and what not. My transfer is also stalled with the SQL, but i’m stuck because it thinks the formatting is wrong. However the instructions I got did not say I had to make the exact same username and password. I assume the database name should be the same, but I had not thought about user name.

I’ll let you know if I disocover anything. I’m sure if DH support is in the house right now.


#5

I re-read your posts and it looks like you are further then me in the transfer. You actually got you sql imported ok. that is where I’m stuck. I’ll show you where I am below, but first I can answer your question about Paulina. That is your server name. Most of the time you just see your site as ftp.yoursite.com, but if you really look at how it exists on the server you can see the server name. for instance i’m on ‘squirt’ and i see home/squirt/mysite.com or something like that. I’m no expert, I’m just a rookie.

Here is where I’m stuck in the sql import:

SQL query:

– phpMyAdmin SQL Dump
– version 2.8.2.4
http://www.phpmyadmin.net

– Host: bhost1.mysite.com.
– Generation Time: Oct 20, 2006 at 11:53 AM
– Server version: 4.1.14
– PHP Version: 4.4.2

– Database: bdatabase1

CREATE DATABASE bdatabase1 DEFAULT CHARACTER SET latin1 COLLATE latin1_swedish_ci;

MySQL said: Documentation
#1007 - Can’t create database ‘bdatabase1’; database exists

So why is it freaking if it exists, if the support people said to create one of the same name when importing?


#6

I didn’t think that would be a problem. Does your restore abort at this point? The next line should say:
USE bdatabase1;

And then it should go on its merry way.

-Scott


#7

Scott,

yeah the restore aborts. that text I posted above is the last I see. The bummer is since I’m transferring between DH accounts I had to (or thought I had to) delete the domain and databases from the old account before setting them up in the new account. So if this file I’m trying to import was somehow exported wrong, I’m toast.

I get a different response if I try to import this file into a database by another name (as opposed to his error which is when I reproduce the hostname, the database name, the user name and the password)

thanks

Paul


#8

Thanks for trying to help the original poster, but a couple of things need to be “set straight”:

Good guess, but not correct. The “.paulina” is not the server name. The servername, per se, does not show up anywhere in the path. The “.paulina” is what Dreamhost calls a “dataglob”. There are several posts about this on these forums, but the short version is that is a process by which dreamhost “groups” data, making it easier to move around should they need to in order to balance server loads.

For the purposes of running scripts on Dreamhost, these "dataglobs"are not relevant. In fact, if there is any place in your scripts’ settings where a path is asked for, and/or should the script automatically populate the field with a path that includes such a “dataglob”, Dreamhost recommends that you delete the “dataglob” part from the indicated path.

This is because it is not needed (Dreamhost handles it automatically), so there is no need for a script to include it. If you do put, or leave, it in the script, it will still work just fine unless Dreamhost should need to change it to rebalance things. If you have left the “dataglob” in the script, after the change it will be “wrong” and the script wont work; if you omit the “dataglob” reference from your script, Dreamhost will adjust to the “new” dataglob setting without intervention.

That said, the original poster’s problem is different than yours (I’ll try to help him/her next), but your problem is pretty simple to fix. You need to change the sql import text that you are using to delete the line:

CREATE DATABASE bdatabase1 DEFAULT CHARACTER SET latin1 COLLATE latin1_swedish_ci;

At Dreamhost, you cannot create databases this way (you must use the panel). After you have created the appropriate database (that is now empty) you do your “import” without the “CREATE DATABASE” line, and the import will populate the existing database with the data that was exported (it will add and populate the tables).

From that point, just proceed as instructed and you should be fine.

BTW - whenever you are having these kinds of problems it helps greatly if you include the instructions you were following. It’s never a good idea to assume that you were each given the same instructions from DH support, and if we can see what you tried to do, we have a better chance of picking up where it went wrong, what needs to be clarified, or what needs to be fixed.

It’s not too late to do that - if you are still hung up, after trying your import without the CREATE DATABASE command, please post the directions you received from DH support, indicate which steps you have completed, and describe your problem as best you can and we will try to help.

–rlparker


#9

bsaires,

Let’s see if we can’t get you sorted out here :wink:

Short answer is, “probably not”. The “.paulina” is what Dreamhost calls a “dataglob”. There are several posts about this on these forums, but the short version is that is a process by which dreamhost “groups” data, making it easier to move around should they need to in order to balance server loads.

For the purposes of running scripts on Dreamhost, these "dataglobs"are not relevant. In fact, if there is any place in your scripts’ settings where a path is asked for, and/or should the script auomatically populate the field with a path that includes such a “dataglob”, Dreamhost recommends that you delete the “dataglob” part from the indicated path.

This is because it is not needed (Dreamhost handles it automatically), so there is no need for a script to include it. If you do put, or leave, it in the script, it will still work just fine unless Dreamhost should need to change it to rebalance things. If you have left the “dataglob” in the script, after the change it will be “wrong” and the script wont work; if you omit the “dataglob” reference from your script, Dreamhost will adjust to the “new” dataglob setting without intervention.

That said, you seem to be on the right track. Many such problems are caused by various ftp clients either faililng to upload all the files when you do “a whole directory tree”, or somehow “borking” the transfer. The first thing you should do to try to fix your problem, from what you have described, is to find the wp-settings.php file, and upload it to the “sitename.com/wp-content” directory. If all else went fine in your transfer process, this may be all you need to do to “fix” the issue.

I am a lttle confused by what you are referring to when you talk about a new “account” - are you meaning a new domain, or an entirely new DH account - it could make a difference as to which term you mean, as you may/maynot have to change the database user/password. For now, just make sure that the wp-settings.php is in the directory as indicated and we can go from there if it isn’t fixed. :wink:

Going forward, whenever you are having these kinds of problems it helps greatly if you include the instructions you were following. If we can see the same instructions from DH support, and if we can see what you tried to do, we have a better chance of picking up where it went wrong, what needs to be clarified, or what needs to be fixed.

–rlparker


#10

please see my response to your previous posting in this thread :wink:

–rlparker


#11

Parker,

Thanks for your help and my apologies for the spreading of mis-information re: paulina.

I have deleted the line in question, and tried to re-import and it works. I really appreciete your help. This was something I’ve been struggling with for 24 hours (well not full time) without any tech support. Now I move on to the next wall in my learning.

Just for historical sake, here is the info tech support gave me for moving a domain from one dh account to another:

[quote]
Moving services such as user accounts and domains from one account to another is a complicated process. In order for this to be accomplished, you must follow this guideline:

  1. Sign up for the new account that this domain is going to be transfered to. If the account is an existing account, please skip to step 3.

  2. While signing up, use a free dreamhosters.com sub-domain (such as mywebsite.dreamhosters.com). This will allow you to keep the free domain registration available and avoid any possible “Domain already in the
    system” errors.

  3. Back up all site files to your computer using an FTP or shell program.

  4. Download all of your emails from the account. If you currently use an IMAP connection process, switch it to POP3 so all mail is removed from the server and available on your hard drive.

  5. Export all of your databases using the “export” feature in
    PHPMyAdmin.

  6. Delete the domain from the “Manage Domain” section in the webpanel (via the current account).

https://panel.dreamhost.com/?tree=domain.manage

  1. Re-create the domain, email addresses and databases on the new account.

  2. Upload your files to the site, and import your database.

http://tinyurl.com/n5rdj

  1. Then have the owner of the new account contact us through the WebPanel with verification to move the registration to their account.[/quote]

Thanks

Paul


#12

No problem, Paul! This is how we all learn :wink: .

Thanks for posting the instructions you received from Dreamhost Tech Support. I’ll take a few minutes and review them while you attempt to proceed with the rest of the steps. If you have further trouble, just post back with the step you are having trouble with and describe the trouble you are having, and we will go from there, ok? Good Luck! :slight_smile:

–rlparker


#13

Sometimes it helps to have “another version” of instructions when you are doing something complicated. While not addressing the “Dreamhost specific” aspects of moving between accounts, this article from the WordPress CodeEx on Moving Wordpress has good information, and may help “fill in the blanks” as it relates to moving your WordPress installation.

–rlparker


#14

RLParker,

Wow, I wish I had seen that before I started down this road. That is a great list that fills in A LOT of gaps. I’m afraid I may be trudging ahead with a few missing pieces here but we’ll see.

Thanks.

Paul


#15

thanks rlparker for the help so far.

the thing is, it is www.sitename.com/wp-content/advanced-cache.php file that is missing. i think it is www.sitename.com/wp-settings.php file which is on line 69 trying to access the advanced-cache.php file, which isn’t there.

to clarify. i can find www.sitename.com/wp-settings.php in the directory in the correct place. i can’t find www.sitename.com/wp-content/advanced-cache.php anywhere, neither in the directory or in the back up files i downloaded to my hard disk.

this worries me!

to answer your other questions, i am moving the website and domain between two different Dreamhost hosting accounts. previously my company had kindly let me put my website/domain on our Dreamhost hosting account, but now I am moving it to my own Dreamhost hosting account (not changing domain).

here are the instructions i was given by Dreamhost support so as to do so:

“It’s a pretty easy process, but does involve quite a bit of work as we
have no automated way of doing this. Basically you need to back up all of
the files on your current account to your local hard drive. Once that’s
done, delete the domain from the current control panel by clicking the [
x ] located next to it here:
https://panel.dreamhost.com/?tree=domain.manage
After that’s done, login to the new control panel and add the domain by
clicking on the ‘Add New Domain’ link found at the URL above. Once the
new domain is added, re-upload all of your files to the appropriate
folder.
Backing up your MySQL database can be a bit tricky, but there’s more
information on how to do that (and later restore it) here:
http://wiki.dreamhost.com/index.php/Backup_MySQL
If you do it through phpMyAdmin, it can later be restored through a
similar method. Instead of exporting it, you’ll be importing it.
Once everything has been restored, you’ll need to go through your
WordPress configuration and ensure that all folder paths have been
updated to reflect the new location. You’ll then be good to go!
Please don’t hesitate to write back if you need help with anything else.”

On reflection, I followed this exactly until the final instruction “go through your
WordPress configuration and ensure that all folder paths have been
updated to reflect the new location.” - what exactly does that mean? what config am i changing and what is different about the location? (it is the same domain name, same files, same mysql database, same hosting company, same nameservers…)

Also, the part about .paulina still has me a little confused (sorry, i am completely new to all of this) - do I need to change any paths anywhere to remove .paulina, and if so, where and how?

finally, i say i followed the instructions, but there were no real clear ones given as to the mysql database import. i just used my intuition for that. maybe i did something wrong there? could a possible error in this step explain anything?

thanks again for your help so far rlparker, i hope we can get this resolved soon (and for the other guy in this thread too - good luck!)


#16

bsaires,

Oosp! My bad! Please forgive me, I mistyped in my previous post. It is the “advanced-cache.php” file that is missing. I apologize; I guess my typing outran my brain on that one (it happens to us all :wink: )

If you did not get that file when you downloaded the “backups” from the old account to your computer, then there is a work-around for not having it. Apparently, your old installation was asking for it as a result of a configuration setting in your wp-config.php file (which is located in your www.sitename.com directory.

There are pretty good instructions on how to deal with this situation in the WordPress Support Forums (prompted by a circumstance similar to yours!) I suggest you check out that reference, do what they recommend for the “fix” and see if that clears everything up. There is a lot of great support the WordPress support forum, and sometimes they are more familiar with the idiosyncracies of WordPress.

Thanks for clarifying that; I understand what you are trying to do.

All those path setting are found in the wp-config.php previously mentioned. It could be that nothing needs to be changed, though the “sitename” you refer to may actually be a “user” name, and it may be different than what you had on the other account. As for the “.paulina” dataglobs, if they (or another “.something”) are present in the wp-settings file, just delete the “.pauline” part (here is a little more info about dataglobs and script settings).

If you got no errors while importing your database, it probably went fine, so I wouldn’t worry about that and it does not appear top be related to your error. :wink:

Good Luck, and if you need more help getting it sorted, post back and we will keep trying.

–rlparker


#17

thanks once more rlparker, i really appreciate your help.

so, i tried the wordpress support solution you provided (to do with the wp-cache plugin), and it has half worked…

now i have my blog homepage back and the wp-admin area for posting/editing etc.

however, all of the other pages are throwing up 404 not found errors (i.e. the post pages, category pages, page pages, archives).

the strange thing is, i can go into admin and write a new post that appears on the homepage. but when i click on its permalink (as with any other link to pages on the homepage) i also get a 404.

any ideas what could be causing that?

the saga continues…

(seriously, i REALLY appreciate your help :slight_smile: thanks)


#18

No problem! It looks like you are “getting there”. Now you should be just down to tweaking some settings. From looking at your URL’s, it appears you are using apache mod_rewrite to form “pretty urls” for your links. As I can’t see your wp back-end, and since you are using re-write rules,I can’t tell transparently which links are pages, which are permalinks, etc. Re-write rules can be tricky.

Again, the WordPress site is the best place to go for getting specific WordPress help, especially when “debugging” something out of the ordinary. This article on fixing permalink problems may be helpful in giving you some general understanding of what is involved, and help make the suggestions that follow make more sense.

There are interactions between the settings for paths in wp-config.php, the settings for permalinks in the WordPress backend settings, the re_write rules you are using in your .htaccess files, and the version of Apache that is running on your server. Presently at Dreamhost, some servers are running instances of Apache 1.3 and others are running 2.0. There have been some reports of problems with WordPress re-write rules and Apache 2.0.

That said, the first thing to check is to “double check” all the settings in wp-config.php to make sure they are accurate for your current set-up. They may very well be (as you are getting pages and all!), but double check to make sure all the settings make sense to you.

The next thing to try is to check your settings in the WordPress backend from the Options -> Permalinks settings page. It appears you have used the last option, “Custom”, and should have some “custom structure” in the box below the “custom structure” radio button. Review this “custom structure” to make sure it is correct for your new server settings. If it is not, make the necessary changes, hit the “update” the permalink structure" submit button, and test your site. You may have to clear your browser cache to see your changes.

If all looks fine with that “custom structure”, try hitting the “update permalink settings” anyway, and test your site.

If neither of these works, we will have to dig a little deeper. One thing you might do as “test”, is to check the “default” settings for the Permalink structure, “update the permalink settings”, and test to see if that works. (Don’t worry, you can “change it back” at any time, and if you are just quickly “testing” search engines are not likely to pick up the “new” urls)

You are almost done, so hang in there, don’t give up, and have confidence that you will get it working. Good luck! :slight_smile:

–rlparker


#19

rlparker, i owe you BIG TIME :slight_smile:

i tested changing permalinks to default, and all of the pages returned with the default ‘unpretty’ link structure.

so anyway, i changed it back to my custom structure straight after, to see what would happen…

…and now everything is back (with browser refreshes), with my pretty link structure intact :slight_smile:

problem solved. it may be 6.41am here in buenos aires, but at least it’s solved, and all thanks to you.

any idea why merely changing permalinks to default and back would have fixed the problem? not that it matters too much anyway now!

one final time, thanks for all of your help.


#20

Good Deal! You are welcome to the help, and I’m very glad you were able to get everything working. Now you can “take your time” and re-install any plug-ins that you need (if you want the wp-cache back, etc.). Don’t forget that the WordPress support forum has most of this stuff in it - you just have to dig around a bit. :wink:

The update permalinks process updates the .htaccess file using the settings in the wp-config.php and the settings on the Options-permalinks page. Some of those settings use “variables” from the environment (which might have changed when you “moved”) and your exisitng .htaccess was just “copied” from the “old” install. “Updating” causes that .htaccess file to be re-created; in this case you probably would have also had success if you had just “updated permalinks” without changing it back and forth (I intimated in my earlier post that you might try that and that it might work :wink: )

I have no idea which particular setting was “borked”, and while I suppose we could continue to investigate out of curiosity, I think the process you went through just works “better”. Once the wp-config.php and backend settings are correct, letting the WordPress software generate the .htaccess rules it wants seems to me to be a good way to go (WordPress is a very well-coded program, and I think those programmers understand this stuff better than I do - so I let “them” handle it) :wink:

–rlparker