Help! Just messed up my site!


#1

I just added a new database, and now my site is gone (wordpress blog) but I didn’t do anything to my wordpress database…so I don’t know what I did :frowning:

when I go to my site it just says
Error establishing a database connection
http://www.lifecapturedphotographybycrystal.com/


#2

is your mysql server named ‘smelt’? http://www.dreamhoststatus.com/


#3

No, it’s “catshark:bobier” MySQL Server


#4

things to check…

can you see the database in the panel?
can you see the hostname in the panel?

compare that information to what is in your wp-config.php file.

Did you create the new database using an existing database user? If so could you have changed the password in the process? or changed it yourself becasue you didn’t knwo what it was? If that’s the case then put the new password in the wp-config.php file.


#5

Yes, I think I did. Do I have to create a new user for each database that is created?
Yes, I also think I changed the password

where can I find the wp-config.php file?


#6

Read this article on editing wp-config.php: http://codex.wordpress.org/Editing_wp-config.php

Edit the file and put the new password in.

What is happening is wordpress uses the password stored in wp-config.php to log into the database and the password is now wrong. Basically the webservers and the database servers are two different things, and this lets wordpress on the webserver know how to ‘login’ to your database server.


#7

Thank you so much!


#8

I can’t open the .php file to edit it?


#9

Have you downloaded it?

How are you trying to open it?

Try opening notepad and using File | Open.

If all the lines are scrunched together (like the Enter key was never used) the file was downloaded in binary mode, change your ftp program to ‘automatic’ or ‘ascii’ mode and download again.

Save it, rename the one on the server if possible-- add .old to the end of the name and then upload the one you just edited.


#10

I opened it in Notepad. Changed the password, re-uploaded via filezilla, but it didn’t work. Then I changed it all back to the original password (in notepad and my wordpress db using UTF-8) and it still isn’t working :frowning:
This is so above what I am familiar with doing.
[hr]
Ok…so the password in the wp-config.php file is the same as the db password when I open it in my dreamhost sql page…and it’s still not working :frowning:


#11

Capitalization of course does count.

Beyond that I’m not sure what else to suggest next, you might want to contact support and see if they can assist since they have access to look, whereas the rest of us here in the forum are mostly other customers without access. Normally they don’t get involved with app (wordpress, in this case) issues, but since this one is about the app making the database connection they may be able to help, I don’t know.


#12

Thank you. I’ve contacted support.
If all else fails, could I just delete my current database and start a new one and import all of my blog all over again? Is it that simple?


#13

Depends what you have uploaded to your blog… its probably not easy unless this is a brand new site that doesn’t really have content yet. The database is going to contain all the blog posts and comments that anyone has made. If you delete the database you really are starting out fresh.


#14

No, I started it in November…so it has content…and good search rankings (for an amateur…lol). So I can’t copy everything from filezilla onto my pc, then just re-upload? crap. Ok I will wait for tech support to see if they can help me.
Thanks for all of your time![hr]
oops…one password apparently had an asterisk. They’ve fixed it now, and my site is back!!! Yay! Thank you for all of your help!