Help installing Gallery 1.4.4



Hey everyone. I’m trying to install Gallery 1.4.4 to my site at I’ve installed Gallery on other hosts without issue, but for some reason Dreamhost is giving me fits.

After uploading the files via FTP, and uploading the blank config.php and .htaccess files, setting the appropriate permissions per the FTP install docs, the setup URL returns the following:

Warning: main(/home/.bambi/nwsrtoc/ failed to open stream: No such file or directory in /home/.bambi/nwsrtoc/ on line 122

Fatal error: main(): Failed opening required ‘/home/.bambi/nwsrtoc/’ (include_path=’.:/usr/local/lib/php’) in /home/.bambi/nwsrtoc/ on line 122

From what I read at this KB article ( I think there is something with the pathing that I don’t know how to edit. In the PHP error message, it lists the path as “/home/.bambi/nwsrtoc/” where I think it should be “/home/nwsrtoc/”

Is this something that I need MOD_REWRITE to fix or am I going the wrong direction?

Thanks in advance for any help!


You should not have to use mod-rewrite or anything like that.

Did you read these instructions, they are very helpful

You do need to run Gallery as php-cgi for it to work at Dreamhost, however.

The .bambi can be ignored


I did read that article, and it was helpful, however not applicable to the problem I am experiencing.

I checked and PHP is indeed running in CGI mode.

I’d like to specify to ignore the ‘.bambi’, however I don’t see anywhere within the configuration to specify this. I presume that the Gallery scripts are pulling an environment variable for the path.

On another note, if I try to perform the shell-based install procedure, I get access denied errors when attempting to chmod the files that I uploaded with FTP.


Found the problem!

I had ‘force lowercase for remote filenames’ enabled in WS_FTP. Problem solved :slight_smile: