Help! Import keeps failing! what is 'php.ini'?

I’m trying to migrate my old blog into my new self-hosted site. I have successfully exported the old blog and saved the file to my computer but when I browse to the file using the WP software and then click on ‘Upload and import file’ here on this side, I keep getting the following error message:

[quote] Sorry, there has been an error.

File is empty. Please upload something more substantial. This error could also be caused by uploads being disabled in your php.ini or by post_max_size being defined as smaller than upload_max_filesize in php.ini.[/quote]

I know the exported file definitely isn’t empty because I opened it and it’s got all the old blog content in there. So what else is wrong? What is the ‘php.ini’ and how to I enable uploads there? Or how do I change the ‘post_max_size’?

Please help!

Thank you

The wiki is your friend:

And click on the 1 link in square brackets to get to that script. You’ll need it if you’re trying to upload a file larger than 7 megs.