Help getting 256 colors in Emacs with PuTTy

software development

#1

Hi there,

I connect to my account with SSH using PuTTy (version .58) on Windows. PuTTy supports 256 colors with the “xterm-256color” terminal type.

http://www.emacswiki.org/cgi-bin/wiki/PuTTY#toc1

I ran the scripts on the page below and saw output that verifies that my shell is able to display 256 colors:

http://thinkhole.org/wp/2006/05/10/howto-secure-firefox-and-im-with-putty/

The problem is that when I try to launch emacs with my TERM environment variable set to “xterm-256color”, I get the following error message:

emacs: Terminal type xterm-256color is not defined.
If that is not the actual type of terminal you have,
use the Bourne shell command TERM=... export TERM' (C-shell:setenv TERM …’) to specify the correct type. It may be necessary
to do unset TERMINFO' (C-shell:unsetenv TERMINFO’) as well.

I’ve looked all over for how to configure emacs to understand a 256 color terminal type but can not get any of them to work. Here are the three scripts that I tried:

http://www.emacswiki.org/cgi-bin/wiki/PuTTY#toc3
http://www.splode.com/~friedman/software/emacs-lisp/src/term/xterm-256color.el
http://nijino.homelinux.net/emacs/xmas-tty-faces256.el

Can anyone help me?

Thanks,
Adam


#2

Not an emacs user here, but did you try setting the variable to “xterm-color” ?

Check out Gordaen’s Knowledge, the blog, and the MR2 page.