Help: FTP issues with filezilla


#1

Since I updated to more recent versions of FileZilla, I’ve been having a terrible time reliably connecting to my account.

If I don’t use SFTP, I get this error about 95% of the time. Note I don’t get this error ALL the time, sometimes it works great. Sometimes, I’ll be able to move between directories and then suddenly start getting the error. It’s

“Error: Disconnected from server: ECONNABORTED - Connection aborted
Error: Failed to retrieve directory listing”

This Filezilla page suggests the error is on Dreamhosts part: http://forum.filezilla-project.org/viewtopic.php?f=2&t=7688

So I tried some googling and came across this page: http://wiki.dreamhost.com/FileZilla_Setup which suggested I use SecureFTP instead. So I meticulously followed the steps (I think) and now I get this error 100% of the time.

Error: Fatal: unable to initialise SFTP on server: could not connect
Error: Could not connect to server
Status: Waiting to retry…

This error repeats every few seconds. So I am totally stumped. Anyone got any idea how I can use Filezilla to connect to Dreamhost. This is a blocking issue!!


#2

Note: I tried opening up ports 21 and 22 on my wireless router, just in case… no change).


#3

Make sure the user has SFTP account privs.

[color=#00CC00]Panel > Users > Manage Users[/color]

Maximum Cash Discount on any plan with MAXCASH

How To Install PHP.INI / ionCube on DreamHost


#4

That’s it! Little tiny 1 line bit of instructions about that buried on the help page there. The thing is, sure I can get SFTP to work now… but not FTP. Does that mean I should grant SFTP access for my clients too (if they have to upload me a file?)

thanks,
B