Help - FTP error - Permission denied


#1

New to DreamHost… Just transfered a dozen sites over, but having trouble. Can anyone please help? I can FTP in my account no problem, but after I edit a file and attempt to save/upload it, I get this error and can’t figure out what the issue is:

Server said: wp-config.php: Permission denied

Error -160: could not start data transfer


#2

Which domain is this for? You have a lot :wink:

I can check file permissions for you.


#3

I have tried it on several and got the same problem, so I assume all of them…


#4

That is so weird. How were you copying these over? They seemed to have retained some old user permissions. I changed them to the ones listed in your panel (which says which user name you’re using). Does it work now?


#5

I used the DreamHost cPanel Importer where it directs you to take a backup from your old host cPanel and then upload it to DreamHost. Yes, it works now. I have quite a few more domains to transfer over. Can you please provide instructions on how I can avoid or fix this issue for the next ones?


#6

Craigan, I just tested your webftp for forchickencoopplans.com and didn’t get any error. I also just emailed you, so if you see that error again or have any questions for me, please don’t hesitate to reply. Thanks!


#7

The reason you didn’t get an error is because “Ipstenu-DH” fixed the permissions. (See her reply in this thread above.) I still need to know how to fix this for the rest of the domains I’m going to import. Thanks.


#8

I changed the owners to your account.

If you know how to use shell access, I just did ‘chown -R yourID:YourGroup foldername’


#9

Awe shoot… I don’t know how to use shell.


#10

That’s okay — the operation Ipstenu did (changing file ownership) is restricted to system administrators anyway.


#11

I don’t know why the cpanel import would use a different owner, though, that was very odd. (I know our importer is in beta, and that may have been a quirk of it…)


#12

My fault, I realized that later – sorry! As for the rest of the domains you need to import, it’d be best for you to submit a ticket for any future domains being brought in with incorrect permissions, and we will manually correct them for you from our end.

Sorry for such an inconvenience. As Ipstenu said, it’s very odd that the cPanel importer would use a different owner. We’re going to be looking into this and if we discover a reason for it, I’ll be sure to let you know.


#13

Hey Craig!

Just wanted to follow up with you… Did you ever have any more trouble with the cPanel Importer and transferring the rest of your domains?