HELP! Can't view or connect ot my own sites


#1

It appears I have blocked myself from viewing, interacting with and connecting via ftp to any site on my own acount at DH.

I kept telling support that the sites were down, only to finally find out that they were only down FOR ME! 3 computers on a home network time out everytime each one attemps to connect with a site on my dreamhost account in any way EXCEPT FOR webftp through the control panel.

DOES ANYONE KNOW HOW THIS COULD HAPPEN? I’ve rebooted my router, rebooted my cable modem, deleted all cookies.

Could I have put an IP block on my own IP somehow?

I’m lost. Please help! Clients going nuts for updates I can’t perform!

Thanks,

Jeff


#2

Do you have an active Firewall between your LAN and the Internet? You mention rebooting your router, many such devices contain an integrated Firewall.

Mark


Save [color=#CC0000]$50[/color] on DreamHost hosting using promo code [color=#CC0000]SAVEMONEY[/color] ( Click for promo code details )


#3

No, its an older linksys with no firewall. I run zone alarm on the machines. I have turned ZA off and tried. No difference.

If I were going to try to block an ip range from reaching my account and sites at DH could I even do it? This really has me stumped.

Thanks for replying!

Jeff


#4

I believe you can block an IP or IP block from accessing your website using a .htaccess file, but I don’t think you can restrict FTP access on an IP address basis.

Is it only FTP that you can not access? Can you still see your sites in a browser? Can you log-in using SSH/Telnet?

I have seen one similar incident a few years ago (not involving DreamHost) and the culprit ended up being Zone Alarm. Apparently disabling it is not enough in some circumstances, try completely un-installing it on one of the systems to see if that makes a difference.

Mark


Save [color=#CC0000]$50[/color] on DreamHost hosting using promo code [color=#CC0000]SAVEMONEY[/color] ( Click for promo code details )


#5

Thanks again!

I can’t view the sites through a browser. I cannot connect via my ftp client. I cannot connect with Putty. All of them time out.

The problem is, ZA runs separately on each of the machines, and they are all affected. If ZA was a problem on one, I would suspect it, but all 3 at the same time?

I’m going to uninstall anyway and try it. Thanks for the lead!

Jeff


#6

I see, the Zone Alarm issue I referred to was simply blocking FTP traffic (for whatever reason). Probably still worth uninstalling ZA on one system, just to eliminate it as a possible cause.

What you are describing sounds a lot like a DNS or routing issue. Can you ping any of your domains from one of your systems?

If not, can you ping the DreamHost server that they are located on? You can find the server by going to Users -> Manage Users in the panel and looking under the Machine column. My server is ‘bixel’, so to ping it I would use ping bixel.dreamhost.com on the command line.

Mark


Save [color=#CC0000]$50[/color] on DreamHost hosting using promo code [color=#CC0000]SAVEMONEY[/color] ( Click for promo code details )


#7

Yeah, uninstalled zone alarm. No difference. Can’t ping yoda, which is my server. Either my router is screwy, or my ISP is blocking me. Why they would do that I don’t know, so I suspect my router. I’ve reset it in the admin. I think there is a reset button in the back. Going to try that now. I tried to bypass it, but it wasn’t simple and I wasn’t ready to go through setting up a new connection yet. Will probably have to contact my ISP for that. Adelphia, my ISP just got taken over by COMCAST, so I’m guessing that will be a pain in the neck call.

A tracert on one of the domains showed a timeout in the first hop. Is that hop from my machine to the router?

THANKS!

Jeff


#8

Normally yes, the first hop would be your router, but it might be your ISPs gateway, depending on how things are configured.

Since your domain seems to be resolving for you, this eliminates a DNS problem, so it appears to be a routing issue, either with your router or (more likely in my opinion) with your ISP.

Anyway, it is getting late (or should I say early :slight_smile: here in Australia and I really must be getting some sleep.

Good luck and I really hope you find the source of your problem. Be sure to post back here if/when you do, as I am very interested in finding out exactly what the problem was.

Mark


Save [color=#CC0000]$50[/color] on DreamHost hosting using promo code [color=#CC0000]SAVEMONEY[/color] ( Click for promo code details )


#9

Thank you for your help. Wish I was in Australia! Called ISP and they said they wouldn’t put a block on a specific range of ip’s, and the tracert pointed to my router. I’ll wait to see what I hear from Dreamhost and if they say router, I’ll run get another one. Its old and probably the culprit. I’ll let you know.

Thanks!

Jeff


#10

I’d love to run linux, but believe it or not its my kids that are stopping me. Apparently my two step daughters did not get the technology gene and just trying to get them to understand a basic file structure is near impossible. If I yanked windows out from under them they would be completely lost and I would have to spend time I don’t have trying to teach them something they don’t want to learn!

I tried a mandriva distribution on one of my machines once but it wouldn’t consistently mount the windows shares and it became a pain.

When the kids are gone, this will be a linux household for sure.

jeff


#11

Ne’er a truer word was spoken! I try my very best to never let those guys touch anything on my home network, and I stand right over them whenever they are around.

It really gets scary when they whip out one of their own CD’s or USB drives - "DROP THAT CD AND STEP AWAY FROM THE KEYBOARD! DO IT NOW! :open_mouth:

–rlparker


#12

It was a company takeover, not a voluntary switch. Was Adelphia. They all went to jail. Now its comcast. I wouldn’t let any of them near my computer either!

Problem is, if its a DNS problem with them, I’ll never get them to sort it out. I’m actually hoping its my router because that would be the easiest way to fix it.

Jeff


#13

Ha! Sounds like one of those “out of the frying pan and into the fire” kinda things to me.

Yeah, I understand… I was just “spoutin’ off” :wink: . You are right though, if they have something messed up on their back-end, it will be a mess getting it sorted - replacing a router (hey, you probably wanted a new one anyway, eh?) is a lot easier, and you can do it yourself!

–rlparker


#14

All done. Resolved. Bad router. Strange - this was a basic Linksys router. No firewall. Yet it failed in a way to only block access to sites on my account at dreamhost. Strange.

Thanks for all the help.

Jeff


#15

Thanks for taking the time to post the eventual cause Jeff, much appreciated.

I suspected it was a routing problem, but I really thought the culprit would prove to be your ISP. Especially given the recent changes in that area.

As to why your router is doing what it is doing; An old router I once used had this ‘black-list’ function, where it would maintain a list of sites that it ‘thought’ I should be protected against. I have no idea how it determined these sites were unsafe, but occasionally it would add one of my favourite sites to its list and cause me some grief. To make matters worse, it took some fiddling in the devices CLI to clear the black-list or disable the function entirely.

I know you said that you had reset the router. My old router had a reset button too, but the procedure to actually reset the device was not too obvious. You had to depress the button during power-on and only release it once the device had fully booted.

Anyway, it is good to hear that you have the problem isolated. Well done :slight_smile:

Mark


Save [color=#CC0000]$50[/color] on DreamHost hosting using promo code [color=#CC0000]SAVEMONEY[/color] ( Click for promo code details )


#16

Thanks for your help Mark.
It sure felt like a conspiracy for a while there. I thought it was my ISP too. I am glad it wasn’t. If it was, I’m sure it would take an act of God to get it ironed out.

Thanks again.

Jeff


#17

Freaky that your site was missing but discussion.dreamhost.com was available…

Wholly